Turn off splash screen

Not sure if this is already implemented but will there be a possibility to turn off the splash screen in V6? I almost never use it and find it rather annoying than useful.
I now even ran into a fucked up situation where I tried opening a file with Rhino 5, Rhino crashed while the splash screen was active and there was no way to get rid of the Rhino window. Every time I tried to force close it using control panel there was a window popping up saying Rhino is not responding and asking me to press “OK” to close it. But that window was BEHIND that splash window so I couldn’t press the OK button nor move the window. I had to save and close all other work I was doing, with that splash screen still in the front, and reboot.

Make a shortcut to the program (if there isn’t already), then open up the properties for that link. In the command-line add /nosplash at the end as an argument for the program.

1 Like

Forgive my lack of knowledge but is it possible to create shortcuts to the program on the taskbar in the bottom? I don’t use the desktop screen really.

Once WIP is installed you can right-click on the entry in the main menu. Select Pin to Taskbar. Once you have done that you can right-click the new taskbar entry, edit its properties to set the option.

I have it set up like that exactly (:


is it WIP only or in V5 also the trick would work?

v5 has the same command line option.

Like this:


great to know, thanks!

And to avoid the splash screen when you open a file?

I’m not aware of a way to pass a command line argument through Windows File Association. This “/nosplash” command line argument only works on shortcuts.

Also, when you install a new WIP, the shortcut is replaced wo you will need to add the command line argument after each time the shortcut is replaced.

It is possible to create a sendto: shortcut that includes the /nosplash parameter. Then you can select “Send To Rhino” from the context menu and it will open the file without showing the splash screen. Peruse google for details on creating a sendto: shortcut :wink:

Also, I think if you put the shortcut on the Desktop and drop a 3dm file on the shortcut icon, it will open without the splash screen if the shortcut has the /nosplash option.

Surely at this point it could just be a setting in the options…


+1 - seems like it would solve it all nicely.

It’s not only when opening files in explorer, it’s also a problem when right-clicking the taskbar icon (for Rhino) and selecting a file, then there’s also no option to use /nosplash

// Rolf

1 Like