How to switch off the start window?

Hi…,

I have here a customer, who doesn’t want the start window at the start of Rhino 5 for Windows (because, when he works with clients, they would see secret files from other projects).

Where to switch off the start window?

Thanks

Michael
www.flexiCAD.com

Finally a thing I know!
You need to use a shortcut for it though.

I guess you are talking about this:

Make a shortcut in your desktop:

Open properties:

Add ‘/nosplash’ to Target.

Close and open Rhino with the shortcut.

Hopefully this helps, I currently don’t know a way to do it without shortcut link.

  • William
4 Likes

Hi William,

yes, this is what he wants.

Thank you very much

Michael
www.flexiCAD.com

Like the idea of doing away with the splash window as Rhino boots up. I tried Poerak’s suggestion only to get the attached message; any ideas?

Hi @Robb,

compare your image with above example. Your slash direction seems to be reversed and the space char before the slash is missing. Any better ?

c.

I get the same error message with the slash either forward or backwards. This leads me to believe that I will have to change the target on my hard drive to include the \nosplash. I’ve attached another window snip indicating the use of a back slash…cheers, Rob

Hi Rob,

I don’t see the space and the forward slash in your shortcut?

Cheers

Michael
www.flexiCAD.com

Hi @rob, does it work if you just paste below in your target field of the link:

"C:\Program Files\Rhinoceros 5.0 (64-bit)\System\Rhino.exe" /nosplash

btw, you might just right click on Desktop, then add a new link to Rhino.exe, name it eg. “RhinoNoSplash”, then once it built the link file, right click on it, go to properties and add the /nosplash part at the end of the target path.

c.

yes, and I have it working. I timed launching with and without the splash screen. It took 3 seconds to get to Rhino ready for action without the splash screen; 6 seconds with the splash screen. While the difference is rather like picking fly poop from pepper, it is quite satisfying none the less. Thanks for you input and cheers, Rob

Ok, there’s the /nosplash workaround… I still would like to see it in Options as an ordinary option to kill this thing once and for all, because if you double click a 3dm file to open it the splash screen will still be there.

gr, Tobias

2 Likes

You can also add /nosplash to the command line for when 3DM files are opened. You need to do a registry tweak:

  1. Open registry editor
  2. Browse to HKEY_CLASSES_ROOT\Rhino5x64.Document\shell\open\command
  3. Edit the (Default) value to look something like "C:\Program Files\Rhinoceros 5 (64-bit)\System\Rhino.exe" "%1" /nosplash

Now, when you double-click 3DM files, Rhino will open without the splash.

Your request is logged as RH-38737.

1 Like

Hi Brian,
Thanks for this great tip! That makes things a lot better! Actually I could have thought of it myself. :sweat:
anyway…

Thanks, Tobias

Hmmm… I cheered too soon. After adding the /nosplash to the shell\open\command double clicking a 3dm will open Rhino but not the file…

Thanks, Tobias

Must be a little depressing for you guys… I know how much work went in the splash screen and the some people just wanna get rid of it

Oh, bummer! I misread this bug before I posted the workaround. Looks like there is no good workaround :frowning:

RH-5802 is fixed in the latest WIP (there won’t be a service release for V5 to fix this).

its so simple to pass away the splash screen,I just delete that particular file from the directory of Rhino5 RhinoSplash.dll and its done…

“C:\Program Files\Rhinoceros 5\System\RhinoSplash.dll”

Just a bump for this, both ways work, shortcut and registry edit, Rhino 6.

thx.