Tube around curve - wall thickness error


#1

When I type the command “Tube”, and select the option “Around curve”, the value field “Wall thickness” creates a tube with an inner diameter of that value, not the specified wall thickness.
When I select the option “Vertical”, everything is ok.

Max.


Creating tubes in Rhino Mac
(Scott Davidson) #2

Max -

Yes, I can see there is a problem here. It is difficult to explain.

When running the Tube command and it asks for the first Radius. If the command is changed at that point to Diameter, then when hitting OK, the wall thickness is skipped. And a radius is created that can give you an incorrect thickness.

The same this will happen then going back to radius.

I notice if I run the command again and do not change from Radius to diameter or back, then I get a proper thickness control.

The important part of the command is actually the radius value not the wall thickness. So, double check the the second radius is correct, The wall thickness is used to modify that values.

The interface seems to have some problems in this area. I will look closer at it to try and figure out exactly what is happeing.


#3

Scott,
I agree that concentrating on the second diameter will yield the correct result. The wallthickness field is wrong in two ways; once I have entered the first diameter, the pair of values for second diameter and wallthickness seem to have no relation to the first. Entering a new wallthickness value does not work, entering results in the “not implemented” error, spacebar results in a space in the entry field. Please note that I am running the option “around curve” in this case.

Max.