Trouble Splitting a Mesh

I am struggling to split this mesh of a horses head with this grid of planes (no need to be done all at once).

I have tried using various different grassshopper tools as attached in the gh doc. but nothing works.
Horse head (7.6 KB)

It trims in some places but in parts ‘towards the bottom and the back’ it will either not split/trim at all or it will produce a strange intersection

And the mesh repair it says the mesh was good?
Yet it said there were 6 faces with opposite normals so when i tried to unify them it said there were no faces to unify.

I was looking to see if there were any solutions or if any at all?
As currently all i am thinking to do is to extract the mesh faces that intersect the trimming plane then double check and split them individually, but i would rather not do that.

The model of the mesh is too large to send unfortunately.


There is no way to help then. These issues are usually specific to the actual mesh in question.

If you have access to the Rhino 7 WIP and you don’t mind loosing a small amount of resolution, I would try running the _QuadRemesh command on this mesh and then try trimming again.

Infact here is a google drive link to of the rhino model of the horse head mesh.

Yes i do have access and that worked. But i want to not reduce the quality of the mesh as much as possible.
do you think that any of the weaverbird functions would work and give me a higher accuracy of mesh?

Hi Sam -

Have you also tried to split the mesh in Rhino 7 (i.e. not in Grasshopper in Rhino 7)?
If you have and it didn’t work, could you upload that mesh to and put the url of this thread in the comments field?
(or open up your Google Drive link as it is currently asking for permissions …)

splitting the mesh in Rhino 7 WIP worked very well, Thank you!