Trimmed Image Re-proportions

Well, I have made 2 gifs which play here, but when I upload either of them, only a still image goes up.
But see if you can trim the picture here to isolate one of the horses. (I tried turning off VIsual Arq, but the problem remains.)
TrimReproportionsImages.3dm (1.7 MB)

Hello- as always, the best way to get help is to post an example file that shows the problem.


This looks like the same issue I reported here:

Hi Mitch - Yes, only the command line in the image only shows the end of the Trim command, no shrink, so I want to see the whole process.


Got it. Here it only happens after shrinking.

Don’t know if there’s a plug-in creating the cut section indicators shown in the image, but that might be something as well.

Right, there is that too - good point. Well, hopefully we can get a file…


I edited the original post to include the file.

Unfortunately the image isn’t embedded in the file. You need to SaveAs and check the “Save Textures” checkbox.

Thanks. Oops. I’ve replaced the file in the original post with a textures-saved file.

Can you describe the exact steps you used to trim the image and when it went bad? I can’t seem to reproduce it here in a couple of simple tests.

Draw rectangle over one of the horses.

OK, I did that, but I can’t make the problem happen here. On your end, does it show up immediately after trimming? I can only make it happen here if I run ShrinkTrimmedSrf after trimming.

Maybe we’re on different versions. I’m on 6 SR33. Somehow mine’s stuck running ShrinkTrimmedSrf by default after each trim.
ShrinkTrimmedSrf actually gives the desired result, but it then doesn’t respond to Untrim.

Ah, V6. IIRC, yes there was a problem with automatic shrinking after trimming at one point. Don’t know if it was ever fixed…

Aparrently not. I’m up to date. (wrt Rhino 6,)

I can’t reproduce the behavior here on V6 either… It acts like V7, I have to force a shrink on the trimmed image in order to see it (which is in itself a bug, but a different issue, already filed).

Are you on SR33?

I am not able to reproduce this here. I’ll see if going back to 6.33 from 6.34 does anything. Are you trimming with the Trim command typed at the command line or from some other UI element? (button, menu, alias etc.)


using the command line.

Still having the issue on Rhino 7