Trim Question


#1

All,

Stupid question I’m sure but its currently got me stumped. How do you trim a hole in a surface if there isn’t an iso line running through the area you want to trim? Is the some kind of hold the alt key to invert the selection thing I"m missing? Basically the only way I’ve come up with to trim the hole in the upper right of the square surface is to use wire cut.

Thanks much,

Dave Driscoll


#2

Hi Dave,

you can either change to a shaded display mode to have something to click on, or alternatively increase the isocurve density in the object properties of your surface to trim. See red arrow in below image (note this is the properties window under windows):

c.


#3

…or use split instead of trim.


#4

Clement and Matt,

Thank you both for the unbelievably fast reply. Totally solved that problem.

However I’ve now got another one. This one should trim but doesn’t. In a parametric modeler I would crank up the model accuracy and pray. Here in Rhino I don’t have a clue what to do. Thoughts, YouTube video, chunk of the manual I should read? In any case thanks much for sorting the first problem.

Dave


#6

I have found trimming 3D surfaces sometimes depends on the viewing angle. To make sure, you can create the intersection curve and use this curve to split the surfaces.

This way you can also verify that your surfaces do really line up as you expect them to. Sometimes the display mesh looks a bit different from what the actual NURBS surface is.


#7

If you want to upload the file I can take a look at it.


#8

Hoodzy,

Thanks much for the offer but I took another couple swings at it and got it trim by messing with the sequencing of the trims. This was one portion of a larger model. As a generic problem though what is the work flow for dealing with something like this in Rhino? In ProE (of ten years ago) or SDRC (of five) I would crank the accuracy up, regenerate the model tree, and if that flopped start extending surfaces, doing intersections of the extended surfaces, and trimming or just deleting the problem surfaces and recreating the desired surface based on the boundary curves. I actually attempted all of the above here and never really got anything that gave me a straight, true, lower order polynomial surface.
While I am far from a programer of CAD software, I do have a decent appreciation for the math behind the geometric forms we’re using here and I’ve got a feeling that this problem is somehow related to an accuracy or minimum calculable feature size issue. There seem to be settings for that kind of thing in the settings menu (go figure) but I really don’t have a good appreciation for how these relate to model size. In this instance my part volume is about a 5 inch cube.

Thanks for the help,

Dave


#9

There’s a FAQ on tolerances, that might help to understand how they work in Rhino. RhinoFAQ

Tolerances are set globally and changes only affect operations to come. So you don’t need to regenerate or rebuild anything.

If some operation fails, you should check the results if involved sub processes. In most cases the result of intersection will give you a clue, why a certain operation fails.