Transparent locked layers?

Is there any way to have locked objects be transparent or faded out while keeping their layer color? Currently the transparency option is only enabled for “Use Specified lock color” option but I am wanting to keep the current color of the layers.

Or perhaps a way to fade out objects below a certain plane?

My main issue currently is I am drafting my floor plans and have each plan on their correct z position so i can later model. But when I need to reference a floor below the colors are matching and can be hard to differentiate between each other.

Hello - not, I think in a display mode, but you can in the V7 beta, set layers to have transparent colors - this is not controlled by their locked status however.

In case these help, for now, here are a couple of scripts to set locked layers to some % of transparency, and one to remove transparency from all layers. V7 Beta.

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes" (278 Bytes) (701 Bytes)



LayerOpaque doesn’t seem to be working here. wtf is wrong with my rhino? that’s two scripts today i can’t run of yours but you have no problem?

Could well be me, I these are very much quick-and-dirty scripts… let me have another look. Any error ar anything at your end?

Dunno - seems OK here so far.


no error, it just runs and exits normally. i really really like this. definitely will be a mainstay in my workflow. ty

where would i go to change it back manually? not that i want to, i was just trying to do it on my own and didn’t see where you were setting the transparency, it’s not in the layer color if i’m not mistaken.

It is in the layer color - in V7 that has alpha:


ahh, i got it, you have to have the layer locked before you run it and also have the locked objects use their properties in display settings. i get it now. ty