Transparency Question-Wish


#1

Hello McN Team

On hidden line view Artistic-Pen- etc, I would like have the option to illustrate tranparent object.
I mainly do architectural work and we use a lot the hidden views. As far as I know currently, we cannot illustrate glass/tranparency on object in this view modes. Traditional CAD programmes are abale to this.

Is there any way to do this? if not canthis be implemented in future release?

thnak you


(Brian James) #2

SetObjectDisplayMode will allow you to make certain objects use another display mode.


#3

Brian,
thank you for the tip. Didnt know the command existed.
unfortunaely it does not work with transparency. Please refer to attach image.

I am using Artistic display mode, and I apply SetObjectDisplayMode then choose rendered for example were I have trancparency on. unfortunately as indicated on the image it does not work.

thank you


(Brian James) #4

Did you assign a material that was transparent and then make the per object display mode ‘Rendered’? It works here as long as you make the assigned material transparent and use the Rendered display mode for that selection. You might want to disable cast shadows for the transparent objects via Object Properties too.

PerObjectDisplay.3dm (1.0 MB)


#5

Yeah that works but if you set the object to something like x-ray were the display mode is overriding the transparency it doesn’t work


(Brian James) #6

You can set transparency for the material used in Xray mode in Options. Does that help?


#7

Nope it doesn’t seem to work. Here is another example with ghosted mode. The object doesn’t match the regular ghosted mode which is what I would expect

.


(Brian James) #8

Check that you have cast shadows enabled for that box. I think that’s the issue because hidden lines is off in Pen mode.


#9

Brian
I did as you discribed it but no luck. I thought it may be an issue with grafix card but it seem other people are having the same issues.
we also want to see the edges from the object behind. if you notice on your attached image they disapear.

thank you


(Brian James) #10

Can you post a ViewCaptureToClipboard of what you see please? The display modes do use the graphics card and it’s installed driver so if you think that is your issue, please also post a screenshot of Options>View>OpenGL and I can try to help more.

For the Artistic mode, hidden lines are an option for the mode but off by default. Artistic and Pen both use the technical mode as a base. If you enable hidden lines and also use a per object display mode with transparency, you should see this…


(Brian James) #11

For that, use this option in the display mode settings…


#12

Brian,
is not working for me. in the attached images I have hiden line on. and object set to render mode.
unfortunetaly it does not work.


(Brian James) #13

Please double check that Hidden lines are enabled in the Pen display mode settings in the Display panel? This in conjunction with the transparent material should work but I don’t see hidden lines behind non-custom display mode objects either which makes me think the hidden lines option isn’t enabled for the active mode.

Also set your Rendered mode back to defaults in Options. I can see it highlighted blue and I’m not sure what other changes to that mode might be playing a part here if indeed hidden lines is enabled in the pen mode.