Transparency fails in viewer


(Jukka Nummi) #1

Hi! Just started with GH & SD aiming to make a product configurator with those. I use premodeled 3d data from rhino, internalized to GH and then uploaded to SD. I just cant get transparent (preset or custom, simple or complex) materials to be transparent in viewer. They appear all opaque. All the other materials work just fine. Is there a bug in viewer or am i missing something? Thank you very much for any help!


(Mathieu Huard) #2

Not sure without seeing your definition, but there is a small bug in the material components which might cause the problem: if you right click and set values directly in the material component (the opacity value, for example), they are not transferred to the viewer.
We will fix this bug in the next couple of weeks. In the meantime, you can easily avoid the bug by connecting an actual slider or ‘Number’ and ‘Color’ components to the inputs that you want to set.

Let me know if that solves your problem, otherwise maybe you can send me your definition and I’ll have a look.


(Jukka Nummi) #3

Thanks Mathieu!

Unfortunately that did not solve the problem. In viewer if i set geometry color to red, adjusting the opacity slider just fades the actual color (0=white, 1=red) while geometry itself stays 100% opaque.

Any other ideas?


(Mathieu Huard) #4

I can see in the latest model you uploaded (https://app.shapediver.com/m/te) that there are several versions of the same geometry on top of each other. This is probably because you are not hiding the preview for all components except shapediver displays components. Notice in my screenshot above how the ‘Mesh’ component has the ‘Preview’ turned off.
This documentation page might prove useful to prevent such problems.


(Jukka Nummi) #5

Thank you very much. That definitely solved my issue!