Toucan - Modifying a material


#1

I just found that when you modify a material in Toucan e.g. color, specularity or other, the change won’t show in your scene unless you you alter the material’s name in some way before saving it. You have then to re-apply the material to objects in your scene.

Tried on different files; seems to be a bug.

I would like somebody to confirm.

Thanks.

Dan


(Brian James) #2

Hi Daniel,

I see a bug too with material renaming but it’s the opposite of what you described. In my test here, I assign a material from the Toucan library>render to see that it worked>edit the material in the toucan material editor>close the editor and save the change>render to test that the change worked. This all works correctly BUT if the material name is changed in the editor and then saved, any material changes will not update what is applied to the model. A reapplication of the material is then required. I’ll file this now… but wanted to explain what I’m seeing in case I misunderstood your post. It sounds like you need to change the material name for changes to take effect whereas I found they would take effect until I changed the name.


#3

Hi Brian,

It seems we have different behaviors in this specific case so I will try to better describe my issue and you might have a look after and confirm or not the differences. I will write the step while I’m doing it;

  1. Launch Rhino, we have now a empty scene;

  2. Create a simple sphere;

  3. Open the Toucan Materials window and duplicate (make a copy) of the Deep Blue plastic material in my Personal Library still within Toucan Materials. I name the new material Test Material;

  4. Assign Test Material to the sphere. We can see now a blue sphere in the viewport that is in Rendered viewport mode;

  5. Launch a rendering (Render from the Render menu); the sphere is blue. Everything is normal;

  6. Double click on Test Material in Toucan Materials to open its properties and change the color to red;

  7. Close the window, it will ask if you want to save, click save;

  8. We can still see a blue sphere in the viewport that is in Rendered viewport mode. This is wrong, the sphere should be red…

  9. Launch a rendering (Render from the Render menu); the sphere is still blue. This is wrong, the sphere should be red

This is the first of the two behaviors I found to either wrong or at least different from what I’m used to in other softwares.

Let’s see what you think about this as a first step.


(Brian James) #4

Thanks for explaining your steps exactly Daniel. This appears to be another bug also related to the material not being updated properly after a change in the editor.

If you reassign the test material, a possible name contradiction also seems to arise that you can see in the materials stored within the model not the libraries. You end up with two ‘test material’ files, one blue and the other red but having the same name.

I’ll file this as well for development to look into. Thanks again.


#5

Thanks Brian.