Toolbar frustration


#1

I am really frustrated with the way Rhino5 handles toolbars and toolbar layouts. A number of times over the past months I open a file or start Rhino5 and ALL tools are gone. Opening the Rhino options screen/toolbars shows my saved .rui file open as expected, but ALL the check marks next to the tools I want to show have been cleared. Obviously I didn’t clear every check mark. What gives?

As I check off the tools I want to see, they appear as I positioned them on my double-screen desktop. Can’t Rhino handle tools as simply as, for example, Adobe Illustrator has done for the past 20 years?
Tool bar .rui files, schemes etc. and it does this. Grrrrrrrrrr


(John Brock) #2

Hi
My guess is you’re running on a laptop, had just finished working on your model, closed Rhino, but quickly closed the lid on the laptop forcing a sleep/hibernation while Windows was saving your work to disk.
Windows caches the writes to be a ‘background’ task. The reason is so the next tool you run will start quickly. Windows doesn’t know you’re going to shut down. One of the things Rhino does when closing is saves the current state of your toolbars.
This background writing can take a minute or so depending on how big the file is and how fast the system is.
Unfortunately, Windows is not very reliable with interrupting cached saves and restoring them when you wake the system. It’s rare, but it does screw up. That’s why we have all of the other autosave, backup, rescue3dm command tools and menu file backups.

How many times have you seen a error when starting that your last Browser session closed unexpectedly? You don’t want that to happen to a model.
So, adopt better computer habits.

1 - Never close the lid on Rhino when it is running.
2 - After closing Rhino, wait 60 seconds or so (doing nothing) to allow Windows to save all the file changes to disk.
3 - When you can, shut down Windows.
That’s what I do personally.
I only close the lid on email and Internet browsing when it doesn’t matter.


#3

Nope. Very, very fast desktop. (as indicated in OP) All the check marks next to the tools in rhino options get cleared.

My “habits” have been developed over 27 years in the graphics business and are exemplary.


(Steve Baer) #4

Are you using the SR8 release candidate? We made some improvements that should help eliminate this bug. It doesn’t happen to everyone, otherwise we would have seen this and fixed it a long time ago.


#5

I’ve had the same problem with my last 5 desktops going back to Rhino 3. As with the OP, good, high end computers, currently running Windows 7 and Rhino 5 SR 7, 64 bit but I had the problem with 32 bit builds as well. I had this problem again recently.

It’s interesting that you (OP) mention Illustrator. I agree with you that Illustrator handles tools better, (Though there is no software I’ve ever hated more. In fact, I do all my 2D line work in Rhino because I find it so much faster and easier.) but I’ve noticed that I always have more problems with Rhino and my computer in general when running Rhino and Illustrator together. If I’m using Rhino alone, I have very few problems, but with illustrator, there are no words for the frustration I experience. Again, This goes back to Rhino 3, Windows XP, and I think CS2. Perhaps there is a Rhino/Illustrator issue? Due to my abhorrence of Illustrator, I’ve been doing more work in Inkscape and seem to have fewer problems with Rhino and my computer in general. Just a thought, I can’t really back any of it up.

Cheers.


#6

I am using Rhino 5.8.40128 – I’ve decided to keep a copy of my usual .rui file in another location on a second disk. If I come across the bug again I’ll try just to copy the saved version back to the usual location and see if that resolves the problem.

Once again, I really did not like the tone and implication of Mr Brock especially after the acknowledgement by Mr Baer of the bug.


#7

Anything on this, McNeel??? You told Me this was uncommon even as I scan the forums and see a lot on this subject. It has been an issue for a long time now.


(Steve Baer) #8

Have you tried the SR8 release candidate? We think we’ve made improvements with respect to this issue in SR8. If you are using SR8 and are still seeing this issue, please let us know.

Thanks


#9

Yes SR8, been stable for a while now but just the other day all went awry. Would it be possible to use a script, plugin, or an external .exe to open a saved group of un-docked menus?