Toolbar Button Move/Edit Text Display Issue

Heya, Rhino V7 here,

I’ve got an issue with the display of the text for the move/edit/copy/link tooltip pop-up thing:

On my monitor, the text is larger and edgy, as if ClearType isn’t on (even though I know it is):

Looking at my monitor through StreamLabs’ live viewer, the text is how it should be:

I’m on the latest Service Release 7 SR29 (7.29.23107.3001.2023-04-17) and running Windows 11.

I’ve been messing around with some settings recently, but I’ve had this issue since right after I upgraded to Windows 11 over the weekend.

I don’t see that here. please run _SystemInfo and copy paste the results back here

Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Educational, build 2023-04-17
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 5-24-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 535.98
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-24-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\xToolbox4Rhino\\xToolBox4Rhino.rhp “xToolBox4Rhino”
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\CommandTracker\7.0.8201.28462\CommandTracker.rhp “CommandTracker” 7.0.8201.28462
C:\Users\Anto\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\DiscordPresence\\DiscordPresence.rhp “DiscordPresence”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I am running the same version of windows and have the same driver installed. Any difference if you disable those plugins that don’t ship with Rhino? Although I give it little chance it will solve it, I’d like to rule that out.

Sure thing.

Just disabled 'em and it still happens

It’s especially confusing because I wasn’t expecting to see it work on my StreamLabs preview.

not sure what else, but do you recall what exactly:

These are what I remember changing:

I made my monitor my primary display since Rhino would display super crisp.

Rhino on primary display:

Rhino on secondary display:

I tried changing this to 110% briefly, but it looked super mega shit so I changed it back:

Oh and my primary display (monitor) is at 100% scaling. My laptop screen is at 125% scaling.

Ok, I’m reading more about custom scaling for Windows:

And this might have been the issue, since I noticed some text in other programs/apps not returning to the default scale.