Toggle Materials panel not working Rhino BETA

Rhino BETA (7.0.20280.13133, 10/6/2020)

Not seeing the Materials panel when I hit the icon image

Command: _-Materials
Choose material editor option ( ShowPanel=No Options ): _ShowPanel
ShowPanel ( Yes No Toggle ): _Toggle
Choose material editor option ( ShowPanel=Yes Options ): _Enter
Choose material editor option ( ShowPanel=Yes Options )

Hmmm.
It pops open here.
What is your current renderer?
Your macro works fine here for both the Legacy Rhino Render and the new Cycles base “Rhino Render”.

Can you open the Materials Panel in the docking container on the right?

Hi John,
It is not in the docking container on the right. It was before, and I was using it quite a bit.

I save the file as version 6 opened and with Rhino version 6 and the material panel is in the docker, and the toggle is working.

One other odd thing I encountered with the latest 7 update, when I dragged an image into a Rhino view the Picture and Wallpaper were greyed out.

Come to think about it, it was working fine until I tried to drag an image that I transferred from WhatsApp. It had one of those very long meaningless names created by the app.

I will try restarting my computer and see what happens.

still broken

In the notification panel there is a note that recommends NVidia Video Driver Update. I will try that.

That can’t hurt but it isn’t likely to help either as it’s not a display problem.

Since you didn’t mention any command line error message, it sounds like Rhino is loading the related plug-ins.

Maybe it’s being opened up off the screen.

Do you sometimes use a second monitor?
Maybe try the “testResetWindowPositions” command., and restart.

Make sure also that the RDK related plug-ins are all loaded (Tools » Options » Plug-ins)

It shows RDK_EtoUI plug-in installed.

Command: -_MaterialEditor
Command: _ShowPanel=_Toggle
Unknown command: _ShowPanel=_Toggle

Both of these need to be Enabled AND Loaded:
Screen Shot 2020-10-12 at 6.28.40 PM

This one was unchecked
image
and was the culprit.

Don’t know how it was disabled :thinking:

Thanks for the help. :+1: :grinning: