Floating editors gone missing

Hi, I just recently started to have the same problem.

I cannot get the Materials, Textures, Environments panels. When I click the “toggle material panel” button nothing really happens and the command line simply shows:

Loading V-Ray for Rhino, version 3.60.02 adv ( Mar 28 2018 )
Loading Rhino Render, version 1.50, Nov 7 2018, 21:39:41
Successfully read file “\xxxxxxxxxx”
Creating meshes… Press Esc to cancel
_Command: -Materials
_Choose material editor option ( ShowPanel=No Options ): ShowPanel
_ShowPanel ( Yes No Toggle ): Toggle
_Choose material editor option ( ShowPanel=Yes Options ): Enter
Choose material editor option ( ShowPanel=Yes Options )
_Command: CommandHistory

The three mentioned plugins are loaded.
The mentioned .dll is not blocked.
Repair install of the newest version didn’t help.

In Tools > Options > Plug-ins ensure that the Render Developemen Kit and related plug-ins are enabled and loaded.

Like I said, the three Render Development Kit plugins are enabled and loaded.

Ah right, sorry. For some reason I thought you meant the v-ray plug-ins (:

Could it be that you have the editors as floating panels that are somehow off-screen? For instance if you had multiple monitors at some point and those editors on one of those that isn’t attached anymore. Or you used to have a high resolution with those on the edge, now with a smaller resolution they’d be outside the area?

No problem!

I do have two screens, both aren’t 4K, though, and windows UI scaling is at 100%. They might have been moved off screen. How can I get them back?

It’s weird because they have always been with my Properties Panel but now they’re gone. Named Views used to float around on the other screen but it always stayed visible.

Browse to folder %APPDATA%\McNeel\Rhinoceros\6.0\settings. With all Rhino completely closed rename the one with window positions in the name to something that ends in .xml.orig instead of .xml. Then start Rhino and see if you now get access to the material editor.

If that didn’t do it you could also rename the settings XML file to have a similar extension after you’ve closed Rhino.

Let me know how it goes.

the window position .xml did it. I had to switch the current renderer to Rhino Renderer and then activate the panel again.

Thank you!

Ok, cool! My guess is that your multi monitor screen layout was changed. Either you changed the order (which screen left in the display settings of Windows), or a recent driver update changed that somehow.

Most important is that you know have a fully functional tool again :slight_smile:

I moved these posts to a new topic, since this is a different cause - hopefully other users can find this then easily if this happens for them :slight_smile:


awesome! thanks!

I learned from @pascal just now that there is also a useful command that you could use next time: testResetWindowPositions

oh i love those test commands! thanks!

Vray disabled those editors when it is the current reneder.