The Toucan renderer in Rhino for Mac is going away

Toucan will not be available in the commercial release of Rhino for Mac and will eventually be removed from the WIP versions of Mac Rhino.

Because Toucan is not compatible with current renderers on Windows Rhino and is not compatible with future McNeel plans for renderers in Rhino, we are not continuing development with it. We do not want Rhino for Mac users using Toucan and creating models that will not be fully supported in the future.

Please use the new version of Rhino Render for compatibility with present and future versions of Rhino.

Hi Marlin,
what is the new renderer like? Don’t say you have to downgrade to windows Rhino Render?
If so then I have to say that it sounds like a bad idea as it is crap.

Windows Rhino already has lots of renderers that are not compatible with other users Rhino files and that is not a problem bigger than mac vs win.

My old Rhino files has V-ray Maxwell, Rhinorender, Flamingo 1, NXT etc stuff on them and they are not future proof. So I have to adjust this when the time comes, IF I need the old files. I don’t see that as a big problem.

Or are you starting to develop cycles for mac? That could make sense if it is decided to use that as the new default render engine.


does this mean hdr images can’t be used for lighting?

or- i’m seeing no difference with these 3 settings…

Once RDK is available on Mac I’ll be working on having RhinoCycles on Mac as well. Original Cycles (from Blender) is already being used a lot on the Mac, so it is possible to have it there as well :smile:



I just installed 5A723, and i only seem to have the Toucan Render panel… where did the Rhino Render panel go?

Also, i HATE the new Object Properties panel with the cascading sub-panels instead of tabs. STRONGLY dislike. I would rather click on a tab than have to scroll down through a list of sub-panels.

Ah, never mind… i found the option to change the current renderer under the Render menu. :smiley:

But i still hate the new Object Properties panel. :wink:

I’m liking the new rendering engine, especially that textures now render live in a pane set to render mode. (Though the tiling/offsets of the textures in a pane in render mode sometimes don’t correspond with how the texture gets mapped when rendering.)

what are you lighting that with?

Heheh… it’s complicated.

There are probably 6 or 8 rectangular lights set up as primary and secondary light sources, and some light and dark planes floating above the guitar to provide highlights and shadows in the reflections.

It helps that I’ve worked as a graphic designer, and have art directed many photo shoots. I’ve picked up some lighting tricks along the way from some excellent photographers. :slight_smile:

I’m have trouble with wood grains the U V direction of the grain does not run the way I need it to with I apply it. I need some help to understand how to apply material to a surface. here is a model that I have been playing withPrinter Table (2.0 MB)

hdr lighting would make it not so complicated :wink:

HDR is totally new to me. I’ve heard of it for photography, but I literally had never heard of it for 3D rendering until today.

If you have some good HDR files with light probe data to share, I’d love to try it out!

There are some on the Food4Rhino site:

Wow, thank you! I’m going to give these a try tomorrow!

Okay, i’m sold. HDRs are awesome!

Now i just need more control over the background and environment positioning, so i don’t have to keep rotating my model around so the lights are hitting it the way i want. :smile:

In the Background section, select the Environment radio button in the upper half, then choose your HDR file there. I don’t understand myself what the three lower checkboxes do. @BrianJ can you explain what all these settings (which are the same as Rhino for Windows) do?

I think the upper part selects the background image (either a flat image or an environment map), and the lower part pulls lighting information from an HDR file.

yeah, it’s something like that but i’m not quite sure the hdr is doing the lighting… only the reflections.

skylight works and the only brightness/intensity control for it - as far as i can gather - is to lighten the ambient color… which is weird :wink:

all the other settings (or turning off all the other settings) give one result which is the same lighting (i think) as whatever the default render display mode is using.

as in, the light is coming from over your left shoulder… if you rotate the model, the light updates where as, if it were hdr, the shadows would stay put regardless of rotating the model.

the hdr as an image works and you can see the hdri in reflections.

From what i’ve been able to tell from experimenting with it, if you don’t have Skylight enabled, it’s using your default lighting, which is the “sun over your left shoulder” light. Turning on Skylight brings in the lighting from the lower HDR you load in. Reflections are pulled in from the upper environment map (which can also be an HDR). So you can use the lighting from one file and the reflections from another, but if you want things to be somewhat realistic, you’d want to use the same file for both.

A couple more experiments:

Is it just me or is the “new” rhino renderer incapable of doing ambient occlusion? if so, it is no substitute for Toucan…