The problem Squish when you apply cylindrical mapping

Hi, everybody. Help fix the problem or work around it. Object A has surface mapping, and object B has cylindrical mapping. After applying the Squish command, they behave differently. Why and how to fix it?

If you want
Squishproblem.3dm (851.3 KB)

Hi Dmitriy,

What worked for me:

Create meshes from the surfaces,
then run command UVEditor and if you follow the command just press apply without any alterations.
This will ‘bake’ the mapping onto the mesh.
Next run squish on the mesh:

Does this help?

1 Like

Hi, thanks for responding. I did everything step by step, but I did not succeed. Where is the error?

Create a mesh from surface

Run command UVEditor

The program asks to specify image
The apply button cannot be clicked without building a rectangle
Build a rectangle and click apply

I run the command Squish and Rhino asks to specify curves.

But mesh has no curves and it is impossible to choose them. What am I doing wrong?


You can hit Enter to skip that.


Thanks. It worked!)

Thanks, Willem. It’s all good!)

1 Like