"The file writing plug-in failed" for PDFs

Hi folks,
I’m attempting to export some linework and hatches to PDF for use in the Affinity suite, which (as of the introduction of Rhino 7) is compatible with the existing layers in my Rhino file (yippee!). However, for the last few weeks, any attempt I make to directly Export to PDF or Export Selected to PDF gives me an error message:

"Failed to save as … The file writing plug-in failed.

Unfortunately, using the Save As PDF function through the Print command doesn’t maintain Rhino’s layers, so it’s a rather unideal method. I haven’t changed any preferences since last updating, and tried resetting my preferences to no avail. I’ve got the plug-in enabled, and I’ve reached the extent of my Rhino knowledge so I’m hoping someone may have some pointers for me and anyone else who stumbles across this thread in the future. Using Rhino 7 7.4 for Mac right now.

Hello - I have not heard of this, I don’t think - does any export work - just a rectangle, for instance?

Please run the SystemInfo command in Rhino and copy/paste the results here.


@pascal Thanks! Here you are:

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01002, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Educational, build 2021-03-19
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 10.15.7 (Build 19H524) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro16,1
Language: en-CA (MacOS default)

AMD Radeon Pro 5500M OpenGL Engine (OpenGL ver:4.1 ATI-3.10.19)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB
Graphics: AMD Radeon Pro 5500M
Displays: Color LCD (264dpi 2x), DELL U2720Q (163dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5500M (8 GB)
Color LCD (1792 x 1120 @ 59 Hz)
DELL U2720Q (1920 x 1080 @ 60 Hz)

USB devices
Bowers & Wilkins: MM-1
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Broadcom: Magic Keyboard
Broadcom: Magic Mouse 2

Third party kernel extensions
ch.tripmode.TripModeNKE (2.0.3) B1CBB944-226A-3B59-B4E6-98513271AAD6

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_PDF.rhp “PDF Export” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.4.21078.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.4.21078.1002

Nothing will export, not even a line. If I print and save PDF from there I can see everything though, just not in any layer structure (several thousand individual layers haha)

But, this is not the breaking factor, correct? when you try one line, it is not in a file with lots of layers, or?


Nope – I also made a brand new file, drew one line, and tried exporting that too… no luck.

one line.3dm (27.8 KB)

Hello - do you ever see the print dialog?
Also, @r.raynor - it is probably just as well to get the most recent service release, 7.5.


1 Like

The print dialog works completely normally. The only instance that this message comes up is when going File > Export / File > Export Selected / File > Export All.

Thanks for this update! My Rhino told me it was up to date this morning, so I’m surprised to see this new release. The problem remains unfortunately.

So, just to make sure - when you Export to pdf, you do see the print dialog, correct? I ask because you should see it even though the command is not obviously related to Print…


Hi -

I take it that this means that it used to work at some point on your system. Did it stop working after an update or just out of the blue? Have you tried installing your previous version to check if that still works?

I see an export dialogue box whenever I use the export command, like this:

Upon selecting ‘PDF’ and clicking export, I receive the original error message.

Using the Print method, I can export to PDF no problem, just without the layer structure I set up in Rhino first. Layers are something Rhino 7 very wonderfully has begun to preserve when exporting for use in Affinity Designer & Publisher:

Hi @wim – it did work up until some point within the last month, maybe two. I believe it was an update that caused this to occur. How might I access Rhino 7 7.1 or 7.2 to test this idea? If so, I could let you know which version allowed me to export to PDF.

Hi -

Service release 2 can be downloaded here: https://files.mcneel.com/rhino/7/mac/releases/rhino_7.2.21012.11002.dmg
On Mac, you don’t have to uninstall the current version to be able to run a previous version. You can unpack and drop on the desktop and rename as, e.g., “Rhino 7.2”.

1 Like

@wim Interesting – 7.2 seems to not let me export to PDF. I’m not sure if it formerly did, or if it was 7.1 that did. I know I had limited internet access for a time and held off downloading large files such as software updates, so it’s possible that I went from 7.1 straight to 7.3 or 7.4. Is there a chance I can test 7.1?

Edit: I also tried exporting to 3dm from 7.2, and using that newly exported file to export to PDF, no luck.

Just in case it helps shed any light, I’ve been having the same problem trying to export a PDF from layouts (I realize it’s not exactly the same situation). I get the whole export dialog – which layouts to include, vector/raster, etc – but then either it gives me the “plug-in failed” message or writes a file with missing things (often text). Here are a couple screenshots, and the rhino file. I’m on a 15-inch, 2018 macbook pro, running Big Sur 11.2.3.

layout-export-test.3dm (3.1 MB)

layout-export-test7.pdf (43.8 KB)

Hi there.
I am encountering the same things on my MAC. I have the latest update 7.6.2 - Now Rhino is constantly crashing … I can not open my files : (

Any thoughts?
(University of Alberta)

Hi Sam - thanks for the example file and details… I see dimension text missing, here. SO far I ahve not had a failure though. Are you exporting with a selection (Export command), or just ExportAll to get everything or does it matter?
RH-64412 Export: drops dimension values

… Just in case someone has some input/thoughts.

Hi Tim - just to make sure - this failure now happens every time, or sometimes, and if sometimes, is it specific to certain files, like the one you posted above?


As far as I can tell, it doesn’t matter (I’ve tried both). I was trying to build a simple model that failed, but could only “break” it as far as the dimensions disappearing. I have a much more complex model that fails to export, but I’d rather not post it publicly. is there a way to send it to you directly?