The cycles render engine option is gone after reinstall

cyclesrenderengine

#1

I guess maybee this is because I reinstalled serengeti and possibly had some plugin installed which now is not there?

Before I had the choice of selecting render engine in the dropdown list. Anyway it seems that cycles is running inside the viewport in raytraced mode so is the plugin or whatever missing needed?


#2

I think you need this.


#3

Yeah… I thought so… but do I REALLY need it… Seems like it renders as it should anyways… Thanks though


(Nathan 'jesterKing' Letwory) #4

I need to check on the Cycles for Rhino plug-in tomorrow. I made some changes that I didn’t test much with the plug-in. I don’t see a reason why it shouldn’t be working still though.


#5

@Roy_Berntsen, Cycles should run in the “Raytraced Viewport” without the plugin. Note that if you make “Cycles for Rhino” the current renderer, it will crash the current WIP once you invoke _Render.

@nathanletwory, are you planning to include commands like _RenderWindow or _RenderInWindow to use cycles as well ? I think this would be a huge timesaver when it works like the renderborder in blender.

c.


#6

The thing is I don’t have the option of choosing cycles as current render. This is because I didn’t install the plugin. It raytraces in the wievport as it should so I don’t see the point in the plugin anyways.


#7

@Roy_Berntsen, the plugin currently was required to render larger than the viewport size and it would allow for a few optimisations too. Eg. you’ll not need the progressive refinement when you are not doing realtime rendering. There is also (hopefully) an option to change the tilesize which can potentially double the render speed using AMD GPUs.

Note that in it’s current state, rendering using the _Render command seems to work again, however, closing the render window brings up an endless running dialog over here with “Abort” and “Retry” buttons which do nothing yet.

@nathanletwory, can you please try to reproduce / add this to the buglist ?

c.


#8

really?! - sounds like little effort but huge profit for about 50% of the users with discrete grafic cards.
that would be very welcome.


#9

Yes, it applies to all GPUs according to this. (scroll down to see the chart about tile sizes). For my GPU (AMD) , i’ve found that i can render fastest in blender if i set it to 640x400 which is a very large tile.

c.


Cycles: finding the optimal tile-size
(Nathan 'jesterKing' Letwory) #10

Note that the core Cycles devs are working on algorithms to determine best tile size automatically. At some point this will be gone. But sure, until then it is a useful tool.


Raytraced: configuring the Cycles engine
#11

it has been a long time since i actually had to render stuff. that was rhino4 i think with vray-for-rhino 1 or 1.5. i also do remember, that setting the right tile size was very important.

it seems, that proper openCL/AMD support is on the horizon, we are just not quite there jet.

@nathanletwory
btw, i hope we will see the cycles commands also to be available in a dedicated sidebar and the settings should be remembered/saved with the file.


Raytraced: configuring the Cycles engine
(Nathan 'jesterKing' Letwory) #12

2 posts were split to a new topic: Raytraced: configuring the Cycles engine