The Curves on surface seem discontinuous

Hi everybody,I am a new C++ coder. I am confused about the curves created by using RhinoShortPath() seem discontinuous when they are displayed in Rhino.
I have checked that they are on the surface but when I rotate the view the discontinuous parts also changed.The surface was created by revolving a curve.Anyone can help me?::>_<::

This is purely a display issue.
When Rhino shades surfaces, a display mesh is created. The faces of this mesh approximate the NURBS surface but deviates from it within the parameters that you can set in the document properties. At places the mesh faces will be in front of the curves, in others behind the curves. You can try and play with the mesh settings to create a finer mesh and see if that improves things.

Also, a command that is related to this type of display issues is TestZBiasFactor. Try and set it to 16. I just tried to make a similar model as the one in your images and it seems to help a bit but not for every angle.

Thank you! It really does work.
Just now I found that the curves show better in the back of the surface, so does this issue have some relationship with the orientation of the surface.
I will refine my mesh.But now it is really annoying that I must adjust it again when restarting the Rhino. Any method to do with C++ in Plugin?

@wxbt probably has to do more with the curvature of the surface rather than the orientation.

Not the orientation, necessarily, but the shape - convex versus concave. On your rotor hub, because of the shape, the mesh faces will lay on the outside of the object - therefore the curves will be more visible on the inside.

The mesh settings are a document property. If you adjust the mesh settings in the template that you are using, these settings will be available after restarting Rhino. I am sure that the properties are exposed to C++ but you will need to get information about that from someone else :wink:

you can always use “Ghost” Preview, not my preferred way of working but it is an option.

That’s right but then I’d rather be in wireframe mode and forget about all meshes at all.

Probably you are right. The curvature analysis seems really bad. I got find a way to modify it.Thank you.

You are really an expert. This time I know more about the question. Thank you:smiley: