Texture mapping mesh


#1

I’m dragging a BMP of a pattern over a mesh and the object in rendered mode only shows the base color of the pattern. Any thoughts?


#2

Hi, looks like your mesh does not have texture coordinates or they are all set to 0,0. To built new texture coordinates, assign a mapping type under Properties / Texture Mapping or use the Unwrap command and check/edit the results with the UVEditor.

c.


#3

Thanks Clement, I tried that, to no avail. Could it possibly be the nature of the pattern or the repeat. I downloaded a simple plaid pattern and was trying to get it to take the contours of the mesh object. Any other thoughts?

M


(Brian James) #4

Hi Peter,

Can you post the file as well as the texture please or embed it before saving in Options>Doc Props>Rendering? Also let us know what rendering engine (if something other than the default Rhino Render) you are using, this can effect the rendered display mode.


#5

Hi, just checked and drag and drop seems to work here on meshes. Try a different image to make shure its not related to your bmp, eg. jpg. If this does not show up, please post the mesh and image.

c.


#6

Hey Brian,
Here’s the file, thanks. The pattern file is a BMP, but I’ve also tried this procedure with a jpeg.

HEad with pattern.3dm (5.5 MB)


(Brian James) #7

Hi Peter,

Can you post the texture map please? I don’t have it in the 3dm. Was this checked before saving the file?


(Brian James) #8

I may not need the texture map Peter. I mocked it up with a Checker texture applied with a Cylindrical map in the attached. The mesh had some small gaps causing the normals to be flipped inward. I used the MeshRepair command to fix the problems. The mesh also didn’t have UV mapping info on it so textures couldn’t be displayed. Check out this video for an overview of how to set up texture mapping for any object http://tips.rhino3d.com/2013/01/uv-mapping-in-v5-rhino.html

The custom Unwrap method has some trouble with this model though and I have asked our developers to look into why. Thanks for sharing the model. Primitive mappings such as planar, box etc. appear to work fine.
HEad with pattern_bjames.zip (5.6 MB)


#9

Thanks Brian!