TextObject preview color is hard to see depending on background/display mode

Here in working with a dark background, it’s very hard to see. In my V6 default setup, the preview color is always black - no matter what the layer or feedback colors are. In my custom work environment it’s worse - the preview is nearly the same as my background color (70 gray), therefore almost invisible. Haven’t figured out why it’s not black in my custom setup - maybe a display mode setting or something.

Oh, and if the viewport is in Rendered mode, if curves are checked, it looks OK, if surfaces are checked, it just shows the inside isocurves but not the outline, and if solids are checked, the preview completely disappears!

I didn’t see a youtrack item for this, but I don’t know if it’s just me that’s seeing this or if its more global…

Hi Mitch - It looks like it follows Feedback color in Options > Appearance > Colors.

-Pascal

Weellllll… That’s what it’s supposed to do… but…

As you can see, the Feedback color is white. This is not what the preview shows though.

image

The above is in Shaded mode, Ghosted is the same. Wireframe mode does show the preview in white as it’s supposed to, but Rendered (med. gray background) doesn’t show it at all. I also tried changing the feedback color, making it black does actually work in Shaded, but it still doesn’t show up in Rendered. As noted above, this is with “solids” checked, “surfaces” are also wonky.

Cheers,
–Mitch

Sorry! TextObject. not Text… I’m with you now…

https://mcneel.myjetbrains.com/youtrack/issue/RH-48312

-Pascal