Text tool for Rhino 6 not working


#1

Hallo, just installed Rhino 6 and want to use the text tool. Doesn’t work at all. Not while using the tool button nor typing text in the command line. How can I get this solved?


Rhino 6.4 requires Win 7 Service Pack 2
#2

Hmm, hard to diagnose this just from the problem description, do you have any further info? Where does it actually fail? Error messages?

If you type _Text, does the dialog come up at all? If so, when you type some text in the box and hit OK, do you get back to the Rhino window with a prompt for insertion point?

Just for good measure, perhaps type SystemInfo in Rhino and post the results here…

–Mitch


#3

Hi Sascha,

one customer reported me, that this should be fixed in the latest version 6.2. Not? What version do you have?

Thanks

Michael
www.flexiCAD.com


#4

Rhino 6 SR2 2018-3-6


#5

Sorry, but nothing at all happens. No dialog box.Once I typed ‘text’ it’s waiting for a new command. Same with using the text tool.

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 7 SP1 (Physical RAM: 64Gb)

GeForce GTX 1070/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files (x86)\Rhinoceros 5\Plug-ins\BoltGen.rhp “BoltGen”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\import_STEP.rhp “STEP Import”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18018.1000\5.5\Flamingo.nXt.rhp “Flamingo nXt 5.5”


#6

OK, that’s weird… Does restarting the computer help?


#7

Nope. Happened last week the same.


#8

A shot in the dark: Could it be that the test dialog box is coming up BEHIND something else on the screen?

Also: when you start to type “text” in the command line, does the dropdown autocomplete list show “text”? What happens if you click that instead of typing the whole word?


#9

Yes. it does autocomplete, but doesn’t change a thing.


(Pascal Golay) #11

Hi Sascha - thanks for the report, I’m checkin with the developers. In the meantime, can you try the SR3 candidate, by enabling ‘Release candidate’ in Options > Updates and Statistics > “Update frequency”

@Sascha_Holland-Kuhn - your Windows is 7, SP1 - is there some reason not to update to SP2?

-Pascal


#15

Good morning Pascal,

doesn’t work too. Same, same.

Sascha


(Wim Dekeyser) #16

I can’t tell from your answer - have you updated to Win 7 SP2?


(Barry Mair) #17

I have noticed the reference to Win 7 SP2 a couple of times today.
What was labelled as SP2 was a “convenience” method of all updates since and including SP1.
My system is Win 7, completely up to date, and is listed as SP1.
https://answers.microsoft.com/en-us/windows/forum/windows_7-update/how-to-obtain-and-install-windows-7-sp2/c2c7009f-3a10-4199-9c89-48e1e883051e

Barry.


#18

Yes. I checked. All up-to-date now. It still doesn’t work. Type in ‘text’ – waiting for command. :frowning:


#19

What is a text tool? Text command and TextObject command work fine on my computer. I use Rhino 6.2 (2018-3-6).


#20

Lucky you. On mine it’s not working. I am using Rhino 6 SR3 2018-3-13.


#21

What happens if you type in -Text ? (with the dash in front)


#22

Doing this I can modify the settings (stile, height, rotate) But I cannot generate text.


#23

Wow, that is very weird. Have you tried to repair the installation?
Right click on Rhino 6 and choose “change”

Also, I wonder if this might be a localization issue - it seems like your Rhino is in English, what is your OS language?


#24

What is not working?