Rhino 6 constantly crashes with Text command

Hi all,

I have noticed that Rhino 6 constantly crashes with Text commands. It happens when I do the following things:
-Double click on an existing piece of text in Rhino
-Copy a text out of a block and paste it in the normal environment
-Type ‘text’, press enter and click on the screen

It happens in various files, on various times, the crash can always be recreated from the auto-save file and all my colleagues experience the same problems with the Text command.

Does anyone know why Rhino 6 is unstable with the Text command? Is this going to be solved?

My work around now is to press ctrl+s every time before I start working with texts, because I already made it a habit of thinking it’s going to crash. :roll_eyes:

Hmm, that isn’t a general problem we have heard about - can you post the results of SystemInfo here ?
(type the command at the command line)

Do all your colleagues have the same type of computer hardware?

Hello - please post the output from Rhino’s SystemInfo command.

-Pascal

ie: same cpu, video card(s), same amount of memory?
also: same Windows version and Rhino version?

Hi!

Me and my colleagues all have different systems, working from mobile workstations, desktops and gaming rigs.

My Systeminfo is pasted below:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: Eldin (SH - R&D)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: MSI

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-18-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1070 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 6-21-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 398.35

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2018
Driver Version: 24.21.13.9835
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Pascal,

I posted my system info below. (or above, not sure how this thread organizes posts) :laughing:

No everyone has a different setup. Differing between various GTX cards and some have a Quadro card.
Also all different processors.

I found something interesting. So I made a file where I put text in a block and I try to copy it and paste it outside of the block.
On my new system (The MSI with GTX) it crashes.
On my old system it doesn’t, see systeminfo below.
Any idea what is going on and how I can solve this on my new system?

System Info old system:
Rhino 6 SR12 2019-1-29 (Rhino 6, 6.12.19029.6381, Git hash:master @ ae9d7fba5fda0b43002dc44a34e059a9a382db04)
License type: Commercial, build 2019-01-29
License details: Cloud Zoo. In use by: Eldin (SH - R&D)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: ELDINFAJKOVIC

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K1000M (NVidia) Memory: 2GB, Driver date: 9-25-2017 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 385.73

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 9-25-2017
Driver Version: 22.21.13.8573
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Things have been changing pretty quickly in Rhino and Nvidia over the last year or so, including in the text area. I see that your Rhino versions are different and neither is the latest release, which is SR 14. Your Nvidia drivers are also out of date for today’s Rhino. I suggest you update Rhino and Nvidia drivers on both machines. If the problem persists after that, update the Intel driver on the MSI machine. For help getting the latest Intel driver search this forum for “Intel driver”.

1 Like

On your new system, the first one you posted, your primary display is set to the Intel, not the Nvidia. Your driver is also almost a year old, so I would update the driver and force the Nvidia card to be the primary.

1 Like

In Properties>View>OpenGL it shows my Nvidia GTX card as the video card.
Or is there something I am missing?

Also how can I force the card to be used by Rhino?

Hmm, I just saw this:

I’m not sure how that affects things. But I think if you go into the Nvidia control panel and create a profile for Rhino and set the OpenGL rendering GPU to the 1070 and power management mode to “prefer maximum performance”, that should make sure that the Nvidia card is used. In any case update the driver and Rhino to the latest versions.

Apparently my GPU works as a hybrid, so disabling the Intel one also won’t let the GTX work.

On a brighter note. I updated (re-installed) all drivers and Rhino. And found that after the Driver update of my Nvidia card the crash stopped happening. So I am very very glad with all the answers you guys gave me, it really pushed me into the right solution! At least, I’m still having my fingers crossed, but it looks to be stable for now.

Thanks a lot Helvetosaur and also you AIW :smiley:
If a crash still occurs in the coming week I will post it here, otherwise the topic can be closed.