Text Tag and Clipping Plane

Hello,

For some reason the text tag component is not displaying in the rhino viewport when I have a clipping plane activated.
Any ideas?

Many thanks,
Miriam

@steve do you know?

2D or 3D text tags? Is the position of the tag clipped by one of your planes?

I tested that with 2D tag and they were completely on the ‘inside’ of the clipping plane - i.e. they should have been visible. I tried both with the .9 version in RH5 and the 1 version in RH6 and got the same result - the tag is invisible.

1 Like

Yes, I made sure the position of the tag was at the correct side.
Problem only with the 2D Tag. 3D Tag works fine, however doesn’t have a parallel view option.
Maybe to expose the view parallelism as an option and keep as only one component? Just an idea.
Thanks!

@stevebaer, the method I use to draw 2D text tags is DisplayPipeline.Draw2dText(string, Color, Point3d, bool, int)

I’ve put a YT item here: https://mcneel.myjetbrains.com/youtrack/issue/RH-37028

@piac you are mentioning the wrong Steve. :blush:

1 Like

Thanks David; I moved this to 6.x since it doesn’t seem to be on the critical path for V6, but I could be confused

I don’t think it’s critical, unless it’s symptomatic of some deep issue causing all sorts of other problems too.

Thinking about it a bit more, I guess I just need to disable clipping planes when drawing 2d text. This is pretty simple; I’ll move it back to 6.0

Well. . .
Are you saying that you will show all 2d text no matter which side of the CP it is falling?

I believe so; I’ll need to investigate a little deeper. Many of the 2d text functions are set up for drawing text on the “screen” and not in world space. In that specific case, clipping planes should not be considered.

Hmm. That would probably not be so nice.

RH-37028 is fixed in the latest Service Release

Hi,

  1. I was wondering if there is any way to control clipping box?

  1. I tried with C# node but got error I think I am missing sth

Error (CS0120): An object reference is required for the non-static field,
method, or property ‘Rhino.Display.DisplayPipeline.Draw2dText
(string, System.Drawing.Color, Rhino.Geometry.Point3d, bool, int)’(line 59)

  private void RunScript(System.Drawing.Color x, object y, ref object A)
  {

    Rhino.Display.DisplayPipeline a = null;
    a.Draw2dText("blllaaa", x, new Rhino.Geometry.Point3d(0, 0, 0), true, 1);

    A = a;

  }
  1. also, I could not find a solution to control Text size according to this method, did you remove Text Tag settings from AppData?
    https://www.grasshopper3d.com/forum/topics/text-tag-size

Thanks @michaldengusiak - that’s a bug. Rhino should be managing the object bounding box for all objects that it draws - you shouldn’t need to do it at all.

https://mcneel.myjetbrains.com/youtrack/issue/RH-58168

@brian thaks for reply, regarding my second question should I log as a separate question?