Text sizing between screen and layout view in Rhino 6

rhino6
unhandled

#1

Just used Rhino 6 for a previous rhino WIP project. Did not use Layout before so never noticed. but the apparent size of Text between the screen view(front. right…) and the rendition on a Layout is really different:
here is a Front view screen shot


Here is teh Layout view:

Notice the apparent different scale for the Text between the two images.

Not critical for me at this stage. Just wanted to let you know.

JMarc


(Pascal Golay) #2

Hi Jean-Marc - see if changing the settings here

makes a difference.

-Pascal


#3

Hi Pascal,
Yes unchecking the “Layout space scaling” did allow me to have same apparent size on View and layout. Not sure what this does exactly and what implication this will have in the future.thanks. But ran into another issue.

This drawing was an export of a group of object from another drawing( assembly). I did some minor modification like adding some notes, adding layout. and some lines were moved or added. I did this before. the above fix you proposed.
Saved the File and try to re-import into the original as a embedded, linked block. Now the position of the object is flipped and the annotation grew 10 times or more…
Original file front view:

Re-import of the object as Embedded block:

I am surprised but can easily deal with the flipping of the object. But what to do with the annotations?

JMarc


(Pascal Golay) #4

Hi Jean-Marc- can you share the file with us ? (www.rhino3d.com/upload to my attention - this upload is confidential)

thanks,

-Pascal


#5

Not sure how to use the link. Click on it goes to blank page. Using Chrome.


(Pascal Golay) #6

Sorry - typo - please try now…

-Pascal


(Pascal Golay) #7

Hi Jeanmarc - the position part is, maybe, due to the active CPlane when the block is inserted - not sure because it seems to work correctly here - that is, if I open the ‘in progress’ file, export everything that is not locked to a new file, then insert that exported file into a clean new file as an embedded block, it looks (almost) exactly the same as the ‘in progress’ file - text size is correct, orientation is correct - the one bad thing so far is that the text is not in front in the Front view, it is invisible in Ghosted unless I explode the block. OK in Shaded.

I do see that your ‘pbc block’ file looks wrong - giant text, flipped… does my description of making the exported file above match what you did?

-Pascal


#8

Pascal, I’m struggling with the same problem, getting my settings right between model space and layout space for my annotations, lets say I have 2 detail windows on a layout page, one is scaled at 1:20, the other at 1:50, my text/dimensions are appearing different sizes, I’d like them both to be the same size no matter the scale of the detail windows on a single layout page. What settings do I need ? tia :slight_smile:


(Pascal Golay) #9

Hello - in this case the text is in model space, correct? You should set the ‘Enable layout space scaling’ as here -
image

does that do it?

-Pascal


#10

yes after using Make2d to get different views for construction drawings i do my annotations in model space, dims, text, leaders etc. I then go over to layouts. Do i need both those boxes checking ? (not at my pc in the office so can’t try)


(Pascal Golay) #11

The layout-space-scaling one is the one that lets you see the text that is in model space at all the same size in a layout, regardless of the detail scaling.

-Pascal


#12

Hi Pascal,

The export process was correct, but I did a) modify the exported file and b)imported back into original file after deletion of the original objects. So I did Some test today and Observed the following:

  1. Exported original parts from “In progress” as new export

  2. Delete original parts

  3. Import as linked block the new Export
    You can see steps on screen shot 00 through 03 attached. The block is flipped around the Xaxis. But the text appear to be correct

  4. Save file as Test 1

  5. Open exported object file verified that apparent position was correct

  6. Re open Test 1 rotate object around X Axis
    Object is now oriented as per original. One thing I noticed is that the gumball orientation of the object at time of the Import(image 04,05):
    [/uploads/default/original/3X/8/8/887b33332a7bb15f53e255a6b7315ae100eb6829.png]

Is different than the Gumball of the object after I closed it and re-opened it:
[/uploads/default/original/3X/1/a/1acff08652a93ed2d028a92d9b9c76caa19b677a.png]
I will have to be clear that I never understood the gumball color scheme and Cplane coordinate.
Then did the follwing

  1. Delete the block

  2. Import original export (image 08,09)
    You will notice that in addition to the rotation, I have huge text.
    So the issue is with the original export. I did:

  3. Added layout

  4. Change Layout scale from Metric to US to match model

  5. Edit the Default annotation profile in the exported file
    As shown on the screen shot, it shows correctly in the Exported file. Something in this must be the issue…

In short the issue is the exported file content not the original file export.

JMarc


(Pascal Golay) #13

Hi Jean-Marc -thanks, I see the flipping, following your steps - still testing…
https://mcneel.myjetbrains.com/youtrack/issue/RH-44630

-Pascal


#14

As mentioned, flipping is a small issue for me as I can easily rectify it. The key issue is the Text size.

Tested today. I was able to change the text of the object by changing the the text Height parameter of the Default font in the receiving file.
Not sure this is quite right. I would assume the source object Default parameters should be used.

Also Please note another small Bug. In the process of testing, I created a Ghost “Block edit window I cannot close”. It appeared because I closed a file when I was still in Block edit mode. Since I cannot get rid of the window.

JMarc