Text Scaling in Layouts

In a previous post, I was told that, in order to get the screen dashes to match the print dashes, I would have to use a layout.

My starting point is a highly annotated drawing:

When I put this in a layout I get this mess:

Until I turn off all the text layers.

Is there some way to scale just the text so that I can preserve what I have in my drawing?

I also note, that the line are not appearing on the screen in the layout as they do in print. Is there some trick to that?

HI Miano,
Somehow I missed your post. Sorry about that.

If the issue is still unresolved, please try this.
Turn off Annotation Scale in File -> Settings -> Annotation.


When this on checked text is displayed its true height on the layout.

So if the text or arrows are 1/4" in the style, they are displayer 1/4" on the layout.
If the text or arrows is 6", it is displayer 6" on the layout. This is where the display gets overwhelmed by the large text or arrows.

You generally have 2 options:

  • Turn off Layout Scaling
  • Or modify the Annotation style for smaller text, arrow and other feature sizes.

The easier being the first option.
If this does not help, we will needs the small model to evaluate. Delete anything sensitive, zip it and attached it to the message.

Let us know if you have any additional questions.
Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Thanks, that appears to work. That leaves me with two layout issues:

  1. The line styles do not appear the same in the layout as they do in the printed output.

  2. Is there some way to open the file then go to the existing layout? The only way I have found is to create a new, dummy layout (to get to the layouts) then delete the new dummy layout.

Hi Miano,

  1. In the Print dialog, pick on the Show details button.


    Pick Linetype and Line Widths

    Pick match Viewport Display (and not Match pattern display.)
    Also while you are here, set the Default pen weight to .25 or something other then hairline (which is typically too fine.)

    You can see the preview of the model changing in the background.

  2. There is no command sequence to script the Layout windows since it is a non-standard window, that I know of. Can you just pick on the Layout button?

Let me know if this helps.
Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Thanks,

I’ve made some progress with that. The dashed lines are now correct. However, other line styles come out as solid lines.

What is the layout button? The only way I have figure to display layouts is to create a new one and delete it.

Hi Miano
What version of Rhino for Windows are you using?
Rhino 5 & 6 Mac have this Layout button.

This is Rhino 5.5. It was not in the original 5.0 release but in the 5.4 release (I believe) that it was added.

I have no idea, other than not having a more current version of Rhino 5 or running your computer at very low resolution, why you do not see this button.

Anyway, hope the images help you know what to look for.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Now I know where the layout button is. Thanks. In regard to the other:

Rhino 6 SR25 2020-4-23 (Public Build, 6.25.20114.03572, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Commercial, build 2020-04-23
License details: Cloud Zoo. In use by: John Miano ()

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G4032) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro15,1
Machine name: Chloe (2)
Language: en-US (MacOS default)

AMD Radeon Pro 560X OpenGL Engine (OpenGL ver:4.1 ATI-2.11.21)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 560X
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro 560X (4 GB)
Color LCD (1680 x 1050)

USB devices
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.25.20114.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.25.20114.3572
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.25.20114.1002