Text object_ Italics cannot be canceled in Rh7

Italics cannot be canceled

1 Like

Hi -

We have that bug on the list as RH-63361 TextObject: Persistent Italic and Bold
-wim

Bump…this appears to still exist.

Hi Nick -

Well, … yes. The issue report is publicly visible and is currently on the 8.x list. This thread is mentioned in the report and will be notified when the issue is resolved.
-wim

My apologies, misread the date, thought it was June 2015.

Hi,

I’m attempting get get my office to adopt Rhino as a primary design software as opposed to Sketchup (I’ve been using Rhino since '08) and this issue is causing a good bit of grief. While it seems like a very minor concern, building templates with textual instructions and quickly adding annotation for diagramming purposes becomes very cumbersome. Is there any way that this fix can be implemented in 7?

Thank you!

Hi Victor -

It needs to be fixed in Rhino 8 first. When that is done, the developer can decide how hard it is / how much damage it can cause to also apply that in Rhino 7.
-wim

Is there any way to reset it or do i need to reset rhino completly if im stuck in this bug?

i am persistently fighting this in v7. fonts dont update properly after style change. bold does not behave correctly. etc. its plagued

1 Like

Hi Felix -

From that YT report, a user reported that switching between the different options will make this work again.
-wim

I’m working on a way to reset this in RhinoCommon. I was actually seeing if I could add superscript/subscript (that’s not so simple). It wasn’t a stretch to explore this.

Any improvements to the text editor would be HUGE. If it was basic but reliable, okay… but I feel like we get the worst of both worlds.

Attached a GH file for anyone who wants to poke around:

RemoveItalics.gh (11.0 KB)

1 Like

you probably will agree with me when i say this kind of bug must be the simplest. wrong update of some database parameters when a change is made. it has not been attended during almost whole v7 lifecycle. its absolutely unpredictable how font style behave when chaning annotation style, or just reopening the file can change the appearance. and the whole logic of textfield is very simple so there is no room for complex dependencies where a bug may occur. this is not the case it is just an unacceptable unfixing obvious simple yet annoying bug.

1 Like

As a workaround, use the command line version, -TextObject, instead of the panel. Italic toggles correctly from the command line.

HTH
Jeremy

Thanks Jeremy :grinning: