Text created by Rhino.AddText in Italics bug

It ignores Italics property change from properties tab.

1 Like

Hello - so far I do not see this:



Rhino.AddText "Text", array(0, 0, 0), 10

(Sorry, there was a 10 in there originally for the height)





It has to be created in Italics…

Windows 10 user: I have been seeing an error along these lines.

Often the text will show in italics when it should not. I switch off the italics button but it’s still in italics.

I re-open addtext and it’s still italics no matter what.

The font is not an “italics font” or anything like that, it is 100% an error in Rhino.

Edit: When it’s stuck in italics I can actually hit “bold” and get it to go back to normal (non bold, non italics) text.

Hello - can you please run SystemInfo in Rhino and post the results? What you’re describing was indeed a bug, as I recall but I believe it was fixed a while ago.


Here is the result of systeminfo:

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Commercial, build 2019-08-23
License details: Cloud Zoo. In use by: Shawn Kay ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.8Gb)

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 11-19-2018 (M-D-Y). OpenGL Ver: 4.5.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build
Driver Date: 11-19-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Any update on this?

Still seeing this bug constantly.

Hi - Could you post the script that is causing this on your system? Also, which version of Rhino are you running now?

  1. Make a text with Rhinoscript in Italics image
  2. Italics button in the properties will not work on this text object

It’s been like this since ver. 14 (that’s when I caught it the first time).

Thanks - I had checked with the python version and that seemed to work fine but, yes, I see this with the Rhinoscript version and have asked the developer to take another look.

RH-53387 is fixed in the latest Service Release Candidate

1 Like

Well, now Rhino.TextObjectText resets text style… :confused:

Hi - could you please add a code snippet that I can run and then file?

Rhino.AddText "some text", Array(0, 0, 0), 12, "ISOCPEUR", 2, 0
Rhino.TextObjectText Rhino.FirstObject, "new text"

I see that, thanks.

RH-58204 RhinoScript TextObjectText resets text style


I am still getting the same error, nothing has fixed it yet.

I am seeing it while using the standard _TextObject command.

I am having this problem too! Usually it fixes itself after several (very annoying) tries, but I’m now working with a file that seems to be cursed with every new text object in italics. I really hope they can fix this bug! Italic annotations can look really unprofessional :frowning:

Hi Lia -

Are you using Python or Rhinoscript? Can you post the part of the script that is causing this?
Also, please run the Rhino SystemInfo command and copy-paste the result here.

Getting this issue right now, cant change out of italics

Please provide a 3dm file, run the Rhino SystemInfo command and copy-paste the result here.