Text blocks in duplicated documents unable to be edited in Rhino 7

When I duplicate a document and begin to make edits in Rhino 7, I often find that the text blocks cannot be edited. I can select them, and I can change the text in the text edit field in the sidebar. However, the changes are never reflected in the actual text. Once I deselect the text, it returns to whatever it previously said. This can be fixed by copying the text and pasting it in place, then deleting the original text. At this point the new copy of the text can be edited like normal. It doesn’t always happen, but if any text in the duplicated document does this, ALL of the text in the document will do it.

Hi Wesley -

I wasn’t able to reproduce that behavior here. Please let us know if you find a pattern that leads up to this.

That bug was fixed in the last few weeks. I tried to find the YT to get the version it went in and can’t locate it. (Not a very good searcher I guess). @johnm fixed it.
Anyway, what version are you running? (first line of SystemInfo output). (@wim)

1 Like

That went into 7.6, which just became a release candidate this week.