Testing new QuadRemesher

That Patch surface has a bad trimmed edge. ExtractSrf > Untrim with keep trim curve > Trim again > Join… fixes the render mesh here. I don’t see this relating to QuadRemesh though :slight_smile:

If you extract the render mesh (which is used by the Quad Remesher) you’ll see that the current Rhino document settings generate a mesh with naked edges and thus you get a poor result. Either improving mesh settings or the box geometry resolves this.

Thanks, filed as https://mcneel.myjetbrains.com/youtrack/issue/RH-57472

@Trav I was filing this at the same moment as it seemed like a bug. I see what’s happening now, it’s a render mesh versus NURBS issue. Maybe we could prompt the user if the two are contrary in terms of naked edges?

1 Like

I think the bigger issue is the render mesh should not produce naked edges.

Yep, I filed a new report and made the first dependent.

1 Like

Thanks
@BrianJ
@Trav

1 Like

Hi all
Here is another example :point_down:




bug.3dm (821.8 KB)

@BrianJ
@Trav
Quad Remesh is not the best at Sharp Point
When we quadremesh, we have problems with Sharp Points and it doesn’t work well.


bug.3dm (826.9 KB)

@mehran09197306634me as stated here before. Sharp points are a current limitation of quad remesh.

1 Like

oh ok
Thanks

RH-57472 is fixed in the latest WIP

1 Like

Woooof! The END of Nightmare for import and export … tnx pros keep continue! however i couldn’t understand why we shouldn’t have Quad mesh in 3d software s by default instead of chaotic meshes. it drives us up to wall. :wink:

REPLY

Hi all
When we run Quadremesh, it doesn’t work properly in the two cases I showed in the photo.


bug.3dm (586.1 KB)
Rhino 7 SR0 2020-7-7 (Public Build, 7.0.20189.15345)

Thanks, I filed it as https://mcneel.myjetbrains.com/youtrack/issue/RH-59451 In this case, not using surface edges works better currently.

1 Like

The RemeshEngine is receiving the good polygon ids about the original NURBS face. (see my comment on https://mcneel.myjetbrains.com/youtrack/issue/RH-59451)

1 Like

Hello,
I was using QuadRemesher with generally good results, but some parts have this issue with shading which I can’t get rid of. Mesh Repair doesn’t show any issues.

Shading stays bad after exporting to other programs too.

quad remesh part.3dm (1.5 MB)

Hi Jakub,

Running _RebuildMeshNormals seems to fix it?

here’s before/after side-by-side:

Best,

G

3 Likes

Yup, it helped, I forgot to check this option too, still learning about the meshes.
Thanks a lot.

Blockquote
Use guide curves to influence edge loops and poly flow.

Wait, this head looks familiar. It it this 3d scan?
I’ve tried to use QuadRemesher for electric plug model. I’ve imported .step file to give this feature a try.
I don’t understand “Use surface edges feature” option. U thought that checking this on would make Rhino to use edges as some kind of guidelines. But instead it simply mess up some parts of a mesh.
For example this is a preview with “use surface edges- off”:


everything looks pretty nice.
Now I turn it to “smart” and get this:
image
It creates kind of a mess in this area. Same result for “strict”.
Also, I need to export an OBJ afterwards (to use in Blender) how can I keep sharp edges sharp when exporting, for proper normals and shading? Sorry. I’m completely new to Rhino, and testing demo to find out if it suits my needs.

There was an initial model that failed but no followup as to whether it works now two years later.