Tested just for you - WIP toolbar editing 😬

sorry, for some reason I missed this @ mention. John is working right now on this part of the UI. I can’t however give you an estimate of when that will be ready.

1 Like

@Helvetosaur yesterday’s WIP has some significant changes in the realm of button editing. The whole workflow of creating toolbars and workspaces is still just as bad as always, but copying, editing, and creating a new button should be much better. What do you think?

Hi Jorgen - is this still the case? Can you save changes to your toolbars?

-Pascal

Hi Charles - please run Reset and set the second option, to discard changes, then re-open Rhino - does that pop-up toolbar propblem still occur?

-Pascal

Hello @pascal

_Reset
So very wanted for a very long time, it’s finally there.
Perfect!

Regarding the pop-up toolbar, it seems to be healed and is ok now.


I repeat the question:

BTW, I like the auto pop out when only moving the mouse over a button with a triangle.
While a bit delay would be better.
And perhaps auto close on mouse leave.

Is it possible to activate the behavior for the standard toolbars as well?

@brian
I started looking at it yesterday, but I am in classes all day today and tomorrow so I haven’t much time to test for now. I did see the “copy the macro” link and was able to create a new button based on a copy of another - the interface is still awful as now the editor dialog is a fixed size panel with no field to edit macros so to edit it has to open a new ‘editor’ window where one can make changes. And all that has to be stored as a new ‘macro’ - so for me too many steps and too much complexity for what was once a simple task. However it does seem to work more or less. I have not tried to modify the button images yet. And with this whole “linked file” mess, I still have no idea where my new button and macro got stored, how it gets saved, backed up etc.

Popup still open sub-toolbars instantly at the moment you mouseover.
Its icons are bigger (why?).
And you can’t relocate it, it always disappear.

There is a way to have it like in rhino 7?
popup
Look how snappy and quick it is…


Each team member have its own UI set up, toolbars etc. But If someone make a good toolbar with many macros and similar, to transfer it to another machine you’ll have to do manually each button or to make a mess by transfering the whole toolbar layout. This is actually a problem since… ever.
There are any plans to let users transfer only specific toolbars from a machine to another?

That’s not in the plan, no.

OK, you asked for it, you got it… Again, warning, long post…

Here is the whole test (maybe 1.5 hours of documentation):

I made a new scheme and started the WIP with that to make sure everything was default. I also made sure that it is the latest version. (8.0.23108.14305, 2023-04-18)

On opening Rhino via the new scheme, I did the following:

  • Docked the command prompt on the bottom (manually - bug report previously filed)
  • Pulled the Osnap panel out of the left sidebar and reduced the left side toolbar to 2 vertical lines to get rid of the ridiculous space-wasting MacRhino arrangement. Docked the Osnaps to the right of the command line noting the ridiculous amount of space that the takes up. The cohabitation of the Selection filter and the Osnaps as tabs in the same container is not good with this arrangement, so I will separate them later. The behavior of the docked Osnap container next to the command line is not stable when resizing the Rhino window (it wasn’t in V7 either) but that would have been a welcome improvement.
  • Pulled the Layers panel out of the ‘Right sidebar’ container and docked it separately under the Properties. It’s hard to hit that little blue dock square – but that will be the subject of a different post.

Now it looks vaguely like my V7/Windows Rhino default arrangement…

OK, to business:

Decided I would create a new toolbar – in the default ‘library’ (whatever that means) because I didn’t dare get into the completely incomprehensible world of ‘linked files’ (whatever that means).

Wanted a blank toolbar with nothing in it to start, but you can’t.

So, OK, I put a copy of the Circle/Center button on it and hit Finish to create my shiny new toolbar.
My idea is to create a simple custom macro that makes a circular surface via Circle>PlanarSrf. The macro looks like this:

! _Circle _Pause _Pause
NoEcho _SelLast _PlanarSrf
_SelPrev _Delete

OK, Shift right-click on the button to edit. I get this:

So I dutifully click where it says (side note, it’s not obvious from the color that the second “Click here…” line is actually a link) and I get this:

I fill in the form:

I am not yet ready to do any image editing, so I leave the original icon. I hit OK to get out of that editor.
I’m feeling adventurous, so I decide to do a right button as well, same macro, but via diameter. Hit the little + sign and I get this:

Fill in the form:

Hmm, I don’t think I can have a different image for the RMB – not going to try that anyway. So I hit OK to close that one. Now I see this:

Hmm, odd – I don’t see the RMB macro. That’s bad, did I make a mistake? Go back into the editor again and check - no, it’s still there, so this is a bug. I notice the little “copy the command script to the clipboard button, so I hit that and paste into a text editor… blank. Nothing copied. Does the button even know there is an RMB macro now? Guess we’ll find out in a minute. Copying the LMB macro to the clipboard does work.

So, finally hit OK to close out of the button editor… My hands are sweaty. So, how did I do?

image

Tooltips are working, although I need to fix them to look more alike. Would have been easier if they were visible at the first editor stage (as they were in V7), but they are not . However, the button actually works. Yay!

Re-open the button editor to fix the tooltips. NOW the RMB macro shows up.

That much seems to be working.

OK, now I’m going to try something really radical – change the button image.

I can’t edit it from the first window (again regression in terms of usefulness), so I have to go into the LMB editor again. At some point later I will simply import another .svg image, but right now I will try the image editor. Hit the button editor and I get this:

Cool, it has a ‘pen’ and a ‘fill’ color, I would like to fill the circle with gold. How do I do that? I don’t see a ‘bucket’ tool. As a matter of fact, only the LMB (black) color works with the pencil or any of the drawing tools, the RMB does not work at all. Mystery. OK, it’s no fun trying to pixel paint on a vector image anyway… So I’ll just settle for making the dot centers yellow.

Seems to work.

And now for the final two experiments:

  1. Close and re-open Rhino via my custom scheme. Cool, the toolbar with the button is still there and everything works.

  1. Now, close that and open the WIP from another scheme – but one that also uses the default library. As I worked in the other scheme with the default library, will I also find my modifications in this one? Nope, the new toolbar created in the other scheme is not there. Nor are either of my two new macros.

So, where are they? Where are those macros actually stored? How do I back them up?

OK, enough for one evening. :face_with_spiral_eyes: :sleeping:

7 Likes

No, it was possible in V7 and earlier to create a new blank .rui, give it a name, then copy any toolbars you wanted into it and save. Then one could bring the .rui file to another machine and open/import it. Very easy, even for just one button. I did this regularly. No idea how this will work in V8.

6 Likes

This is a must functionality. We need to have a way to share a .rui with only a few tools/toolbars.

We need to have a way to continue to do this.

Why are all these regression even happening?

Is anyone at McNeel today working, managing or overseeing the workspace work aware of what V7 was capable of?

We cannot have any regressions. Unless they are solutions now made obsolete and replaced by a better/easier way to achieve the same goal.

G

6 Likes

RH-74399 Copy toolbars from default to custom RUI

I’ve created this yt regarding macro libraries, as I think that is what they need to be called.
RH-74379 Add a section called macro libraries

I’ve added RH-74398 Creating and saving custom macro collections / toolbars

I can’t repeat that here. I wonder if schemes mean something else than what I think. This is a custom Window Layout right?

That’s indeed a bug. I listed RH-74400 Button editor refresh issue

yes and no. Since the icons are now tied to macros, if you use an existing macro, it will show the associated icon of it there.

Nope:
https://wiki.mcneel.com/rhino/schemes?s[]=scheme

How does that work? if you have two different macros with two different images for LMB/RMB on the same button, which one is shown and when?

Edit:
Let me elaborate on schemes and how I work with them.
As I live in a country with 4 national languages plus an unofficial fifth language (English) - which happens to be my native language - I am required to do support and teaching in several of them: English, French and German. In this respect, Rhino schemes are a godsend, allowing me to create desktop shortcuts that start Rhino in any one of those three languages and with a given set of options - including which .rui’s are loaded.

I have ‘Default’ icons for English, French and German which open Rhino as basically ‘as installed’ - with just a few minor tweaks - and I use these for teaching, documenting, and testing. Then I also have a personal scheme which opens in English and with my own highly customized workspace.

All of the three ‘Default’ schemes share the same default.rui (that’s how V7 is set up). If I add a button to the default.rui while working in the English scheme, and then close Rhino and re-open it using the French scheme, the button I created is there because it was made a part of the default.rui. I’m not saying this is either a good or bad thing, it’s just how it works - and at least I know where my new button lives.

Currently in V8, as outlined by the test above, I no longer know where this button (or toolbar) lives or is stored, it is obviously no longer part of the default ‘library’ - which, if I understood correctly, is deliberately not modify-able.

the image is only there to show the associated macro if it exists, other than that it will not show in the UI. In other words, contrary to V7 and earlier, once you make a macro and add a button image to it, the two are tied together.

as for the schemes, thanks for the additional info. I will need to do some testing to be sure, but do I understand correctly that this creates a new set of xml files based on the default? As mentioned earlier, changes are now stored in those xml files, so that’s then the only place where those changes live.
(%AppData%\McNeel\Rhinoceros\8.0\settings)
This means that a change in one set of xml files is not ported to the other

Yes. Not only that, it creates new registry entries for each scheme. There doesn’t seem to be much info in those entries, but if you delete one from the registry, it is no longer recognized from the shortcut.

I see V8 creates some additional folders in settings:

I didn’t see anything in the settings-scheme.xml that mentioned a new toolbar or the macro I made, so I looked in the file above

C:\Users\...\8.0\settings\Scheme__BEdit\Rhino.UI.Resources.rui.default_c7da84fc-2991-4824-832a-4f2509bd0ede.xml

and found this:

So I guess that’s where new stuff for that scheme lives It still seems a lot less clear than the old system and we haven’t even gotten into making ‘linked’ files yet.

Hi @Helvetosaur Mitch. As you’ve written more on the subject of V8 toolbar editing than any “Help file” I’ve seen, would you say that this thread is the most comprehensive reference to date? Is there anything new to add?

I have an uneasy sense that information related to this subject could go out of date very quickly at the moment.

If I want to edit the MMB Popup toolbar, is the easiest way to call a floating copy of it (how do I do even that now??), dock it, then add buttons and edit them using the methods you’ve detailed above?

Must admit, I’m not looking forward to this. I haven’t got a Degree in coding.

1 Like

@MattE yes this part of the UI is still in flux, the next WIP will have a button editor that is much closer to Windows V7.

I really hope this is just a WIP behavior that will be fixed. I guess I’m in a super minority here, but I have my toolbar RUI in an iCloud folder, so I can get the same toolbars both at work and at home (which currently also has some issues).

At one time I was hoping to place the toolbar RUI on a network share at work (which is why I prefer .py files for scripts that can be directly added to a button and saved in said RUI and not .rhp which require manual installation as a separate step and thus aren’t as streamlined for administrating many users), but we ended up never deploying Rhino…

Hi there,

after installing the new WIP ((8.0.23129.12305, 2023-05-09), text titles of floating toolbar groups are missing:

grafik

Also, the small icons of tabs are wrong, I’ve never defined above help icon as toolbar tab icon. Some icons in the toolbar tabs and in the toolbar itself are replaced with gray circles ?!

PS. Are there any news with making a floating toolbar only one row high or saving (and remembering) the panel layout ?

thanks,
c.

MMB popup is still (almost) unusable…

3 Likes