No toolbars or "UI" folder in new WIP install


#1

Just downloaded the V6 WIP from the link in the first post in this category. When I ran it for the first time, there were no toolbars, I looked in the toolbar section in Options and no .rui file was loaded. So, went to load one and found that in my installation,

C:\Users\<me>\AppData\Roaming\McNeel\Rhinoceros\6.0

does not even have a “UI” folder with .rui’s in it as V5 does. What might be going on there?

Edit: I manually added a “UI” folder in the above directory and popped a copy of my current V5 custom .rui in there. Then from inside the WIP, in Options>Toolbars, I ran File>Open and it went straight to that folder… So Rhino knows where to look :smile:

Thanks,
–Mitch


(Steve Baer) #2

@JohnM can you follow up on this?


(John Morse) #3

I uninstalled my current Rhino 6 and cleaned up any files left behind then did a clean re-install and was able to duplicate the problem. I am in the process of trying to track down why it is happening and will do my best to have it fixed in the next public build.


(John Morse) #4

If you close your Rhino 6 and delete your UI folder then restart Rhino does a default.rui file get created and opened?


#5

Yes, it does…

–Mitch


(John Morse) #6

Thanks, it is suppose to self extract if it is not found when Rhino starts.