Terrain renders flat when I export to stl

Hi All,

So I imported a terrain and when I generated an stl file and imported it into my CAM program, the terrain was all flat not smoothed out. I then found out about the FlatShade mode and when rendered it looks exactly like the CAM program. So my question is how to I export the stl so that it is smoothed and not flat. I’ve included a small portion of the 3ds file to show my issue.

Thanks in advance

SampleTerrain.3dm (256.2 KB)

When you say that, I guess you mean that it looks faceted - not completely flat (sort of “pixellized” instead of smooth). This is normal, you are converting a smooth NURBS surface into a mesh - STL is a mesh format - which “pixellizes” (the correct term is “tessellates”) the surface into discrete facets.

Several things can be done.

  1. Make a finer mesh. This is done by adjusting the STL export settings. The idea is to create small enough factes (pixels) that you no longer see them when the surface is machined.

  2. Use a CAM program that accepts NURBS surfaces directly. The tesselation will still be done behind the scenes in CAM, but you have control over surface roughness there.

You should read this web page for more info on meshing settings - also applies to STL export…

HTH, --Mitch