STL file exported from 5 appears not smooth in 4


#1

Hi,

I exported an STL file from rhino 5 Mac, when opening it in rhino 4 on a Windows platform it is not smooth as it is when opening the STL file on rhino 5 Mac.

What to do?
Do you have a specific way of exporting?

Cheers and thank you in advance
Itai


#2

There shouldn’t be any difference physically. An STL is composed completely of triangles (facets), and it doesn’t change from one computer or OS to the next. What you are probably seeing is that the display is different, there may be more visual smoothing of the facets going on with V5 Mac than in V4 Windows.

Try this on both computers: Maximize Perspective view. In the Viewport menu, check “Flat Shade”. That will show you the STL exactly as it is with all the facets, because it removes the visual smoothing from the display. It should then look more or less the same on both (well, the Mac does have a nicer screen than most PC’s, but that’s just hardware.)

–Mitch


(Tim Hemmelman) #3

Hi Itai,

Mitch is right, STL is a standard and thus exporting from different versions of Rhino will not change the output. The only differences that may impact the STL file itself is the mesh parameters you use and whether you choose ascii or binary as your final output. That being said, there is one significant difference between the STL imports on Rhino 4 and Rhino 5 (the code stream the Mac product is based on). V5 allows a user to “Weld” edges on import (in fact that’s the default behavior). So the vertexes, of faces that share an edge and have an angle between face normals that is less than the angle in the dialog, are combined and the vertex normals are averaged producing the smoothed look. If you uncheck Weld, you’ll get the same look (and fundamentally the same model) in both V4 and V5 without doing anything else.

Tim


#4

Mitch is right. it was the Flat Shade that was the issue.

Thank you very much :smile: