Tabs are woefully bad


#1

Hi,

  1. Layer panel does not redraw and allow one to select items or do anything unless I switch to another tab then go back to layers I noticed this happening quite a bit.

  2. I can’t create a new material sometimes in larger files. I have to select an object and then hit the new material tab. Then select new, custom.

  3. Materials tab is still not redrawing correctly.
    4.When I click on new material custom, Rhino doesn’t highlight the material in the material list.
    5.Making the side panel tabs narrower causes all sorts of glitches materials don’t even redraw, layers can’t be created.

  4. Material editor is woefully lacking still I don’t see one improvement in it over the bad implementation of V5. There is a major flaw in the way it displays, it still takes too long to use, I can’t select materials etc. nor find object’s materials.

Please create a material editor that works well. I can’t believe RMA has left the material editor as a tab that is fraught with windows draw disorders. I find V6 is working worse than V5.
RM


(Nathan 'jesterKing' Letwory) #2

Any proposals for improvement you could give?

@andy, maybe a topic you are interested in, too.


#3

Hi Nathan,

I know you guys are working hard on this especially Andy so I feel bad writing this but
I’ve tried to deal with this, rendering small projects is ok but once I get into larger projects this material editor stops working.

I can’t find materials because the names don’t display and the images just suck or won’t redraw.

If I select an object I can’t find it’s material easily and worse it’s a pain trying to create a new material for an object but I think there is a bug there.

Material redraws are not working well and
Texture mapping is a pain too.
You guys have everything all over the place, like settings for the same thing repeated in 2 or 3 different areas. Render settings are in property settings and render tab. Do they need to still be in properties? They don’t update correctly if I have diffuse light set in the settings it’s not checked in the render tab although it shows in the viewport.

uvw repeats are in the texture and in the uvw mapping uvw texture repeating is another thing that doesn’t work.
RM


(Andrew le Bihan) #4

RM

Are you specifically talking about V6 here? Or does this also happen in V5?

We have made a huge amount of changes “under the skin” for V6, mainly to support our effort on getting all of these things working on the Mac. I will look carefully at this over the coming days to improve matters on large models.

Could you give me specific examples of where you see things repeated in 2 or 3 different places (BTW - I don’t necessarily think this is a bad thing). Which render settings do you see in “Properties”? Could you show screen captures? I’m not understanding this at all.

  • Andy

(Andrew le Bihan) #5

RM

Could you explain “woefully lacking” ?

  • Andy

(John Croudy) #6

Hi RM,

I understand that when the file gets large it becomes difficult to create a new material. Can you tell me how you create one when the file is small? The size of the list shouldn’t make any difference. If it does, I’d like to know what the difference is.

You said the material names don’t display. This could be because the Show Labels option is turned off. Right-click on a material preview and find Show Labels under the Thumbnails sub-menu. If the option is turned on and you still can’t see the labels, it would be helpful if you could attach a screenshot of this.

When you say the materials tab is not redrawing correctly, what exactly is the problem you are seeing? Is it, for example, missing graphics, overlapping items, or garbled display? Are you referring to the previews at the top or the settings panes at the bottom? Could you attach a screenshot with the problem areas highlighted?

If you select an object and can’t find its material easily, you are probably looking in the Material Editor which shows all materials. It’s better to go to the object material page under object Properties. This only displays the material for the selected object(s). You can change the material assignment by clicking on the drop-down list.

I hope this helps.

John


(Dale Fugier) #7

Being that very little has changed in the Layers panel, I’d like to know more about this. Does the behavior you describe when you first open the Rhino WIP or after you’ve done a few things. Has this been happen for a while? Any additional information you can provide might be helpful.

– Dale


#8

Hi John, Andy, Dale, Nathan

I don’t differentiate if the file is small or large to create a material I go to the materials tab, click new material, then select the custom type from the list. Then Rhino will go or show that new custom material highlighted in blue with the name field ready to be filled in. But yesterday in this file Rhino would never proceeded to highlight the name nor even create the material in the materials tab.

Then I noticed this, I could select an object, then go to its properties then go to material new and I could create a new custom material and name it but the name and material didn’t show in the material tab, but the name showed if I reselected the object and looked in the object properties tab but they never showed in the materials tab/editor.

Also Materials and their names were just not redrawing the tab was white and some characters displayed then some materials redrew while others did not. If selected an object the materials never highlighted in yellow in the materials tab.

I then opened the uvw editor to move a texture and had the tabs narrowed to the side so I could see the larger viewport, I then undocked the materials tab and did the first part of the uvw command but canceled the command, the uvw editor turned white and wouldn’t stop flashing. I had to crtl alt del. Luckily I had saved the file earlier while I did the above material edits. Even though Rhino locked and I had to bail her.

I experienced the effect with the layers that creating a new layer or even trying to highlight a layer to make it current did not work. I had to go to any other tab and then click back on the layers tab to get the above to work.

I opened the bailed file today and now the materials are showing in the materials tab that weren’t showing before, if I create a new material it is created in the list and it’s name field is highlighted. Also no problems in the layer tab but I’m just casually inspecting this file now and not working in it.

I was doing make 2ds (which also crashed on escape you have my sent in crash reports for those) and lots of rendering with occasional escape to abort and organizing layers, creating materials. I am really thankful to you guys that I am able to get this file working even though Rhino crashed. I think the V6 is working pretty good, I’m using it for production so it’s heavy hours and I really like the way make 2d is working it’s really faster than I’m used to.

I think in the future you might consider getting the material editor off the tab I tried the material editor not tabbed and I think it needs a minimize button or better yet a roll up like Gh does.

In fact I’d love the material editor to have the look and nice icons and clean interface ala GH. We need a wire parameter view for materials too like in max but use a GH type looking interface not just the tabbed interface. Windows tabs seem like a crutch from when Rhino didn’t do Rendering, you guys have out grown the tab and make the library part of or connected to the Material editor.

Same goes for layers and with layers it should be one click to save layer order instead of the layer order manager tab this should all be combined. The layers can still have a tab aspect but I think you pushed windows forms to their limit, I’d love it if you gave us some aspect of customization of the tabs and the commands on them let us customize at least parts of them. Many people have written good suggestions I don’t think you will be able to accomplish what we want with only windows tabs and that limited paradigm.

Rhino exceeds what can be done on a tab, Max creates an interface instead and always lets the tabs be simpler because they are slender. Their layer manager is not a tab because layers are getting too complex and need more options then what can go on a tab. Rendering Materials are the same.

RM


(John Croudy) #9

Hi RM,

Thanks for the explanation. This is no doubt a bug and one that I have never seen happen during development. Rest assured that we will hunt it down and fix it.

Am I right in assuming that this problem happens after several hours of constant use? If so, I already have a clue about what to look at. Thanks again for your efforts to explain this.

I can’t comment on the UV Editor or the Layers because I only work on the Material Editor. I’m sorry for your pain but this is why we release WIPs, so that people like you will find and report these kinds of problems. Your feedback is invaluable; without it we would never find these bugs.

I’m looking at all these Material Editor issues as a matter of priority.

Thanks for your patience.

John


(John Croudy) #10

Hi RM,

I have just committed what I hope is a fix for your problem with the materials not being drawn properly. There was a very clear error which would only become apparent after using the material editor continuously for a long time without starting a new document. I am continuing to look at other problems such as slow performance with large files. I’d be interested to know just how many materials your large file contains. In fact, it would be very helpful to have a copy of the actual 3dm file, but I understand if that’s not possible.

John


#11

Hi John,

I’m always glad to help our that’s why I use the wips for production I know McNeel needs people to do intensive testing and besides I use the wips for production work because McNeel makes such a good product that I can really use it for hours. I don’t have that many materials in the file maybe 25 of them. I can send you the file let me know your email if you need still need the file it’s around 60 meg.

Thanks for your hard work and for your quick response.
RM


(John Croudy) #12

Hi RM,

I have PM’d you my email address. I’m surprised that you only have 25 materials in the file. I was expecting far more than that. The Material Editor should have had no trouble at all with 25 materials. But please, send me the file and I’ll see what other information I can get from it.

Thanks,

John


(Brian Gillespie) #13

https://mcneel.myjetbrains.com/youtrack/issue/RH-36049 is fixed in Rhino WIP 6.0.16306.09301, just released.