Sweep2 Rhino7

Hello there. I’ve been working on fixing a bug with one of our products and I noticed that sweep2 isn’t giving me the results I would anticipate in Rhino7. Our code has worked in the past, but is only starting to give bad results as we are trying to switch over to Rhino7.

Here’s what I get when I use Brep.CreateFromSweep

Here’s what I get when I use Sweep2 in the Rhino Document

I have included a small test plugin and a 3dm with the curves in question that I’m trying to sweep. All you need to do with the plugin is use the Sweep2TestCommand and you’ll be able to reproduce the messed up sweep. The curves have somewhat peculiar points due to our code that blends the corners, but since it works using Sweep2 provided in Rhino and not Brep.CreateFromSweep I don’t think that should be an issue. Hope y’all can help me figure out what’s going wrong.
Sweep2Test.zip (132.3 KB)

Hey @jed_segura,

I am not able reproduce the odd results you’ve posted. What Rhino 7 service release do you have?

– Dale


Hm, really? It’s been easily reproducible over here. You used the file and command I have zipped up yeah?

Here is what I get:


I’m using an internal Rhino 7 SR8 build.

– Dale

Welp, it looks like SR8 fixes it. Hurray you fixed it, thanks man!