Surface Flatness / Curvature / PlanarSrf Question

This is one detail I never noticed before until I needed to export the Rhino model to SketchUp.

During modeling in Rhino 8 Ghostview, Sometimes the isocurve shows up, and sometimes not. It seems when the isocurve shows up, it is not considered a planar surface anymore. I used SelPlanarSrf to make a selection, all the surfaces with isocurve got skipped.

Found two ways to fix this:

  1. By simply moving the edge within the same plane.
  2. DupBoarder then PlanarSrf

Then I tried to understand why. I went to Grasshopper to check the flatness and curvatures of these surfaces. Here are the results:

  1. The flatness component thinks they are all flat.
  2. For some surfaces, the curvatures show (at a given point on its uv) jumping between 0 and -0.
  3. Some of the surfaces with a curvature 0, are not treated as planar surfaces.

I tried to use all kinds of components in Grasshopper, like projection, rebuild, boundary surface, etc, no luck in fixing this.

Could anyone help me understand what is happening and how to fix this?

Thank you,

Surface Curvature Question
Curvature Check

ew why though :sob:

Best way to fix it:

“some technology shouldn’t exist”

Therefore don’t use SU :joy:

what :face_with_monocle: :thinking: :thought_balloon:

0 and -0 are prbably the same thing imo.

and there’s a few things that can cause isocurves to not be visible, it doesn’t necessarily mean they’re not flat / planar …

this gif is super fast, hard for me to see what’s happening :joy:

oh i see, selplanarsrf hhmm weird… :thinking:

I wonder if that other srf is locked or something :sweat_smile:

Hello - please post an example file.


1 Like

Ah, I forgot to attach the rhino file… Here it is.

Thanks, Pascal!
Surface issue.3dm (470.1 KB)

1 Like

Hello- your objects are very far from the World origin - that will cause some precision problems

Point in world coordinates = 10531502.28422,12307390.02411,6896.95166



Haha, I know! It is weird. it is the first time I ran into this +0, -0, and 0 curvature not equal to flat.

Our client needs the final model to be in SketchUp format. Run into this issue during the testing. But curious to know why.

The other surfaces are not locked. I think this is a new feature in Rhino 8. For example, in ghost view Rhino 7, if you explode a box, all the surfaces will show isocurves. In Rhino 8, if you explode a box, none of the surfaces show isocurve. Until you run into this condition I described during modeling. This situation appears to be very random to me.

1 Like

Oh, good catch! This might be the reason. I will try near 0,0,0.
Yes, It is geolocated using the UTM projection coordinate system. I can move the geometry back and forth though.

1 Like

You are right! This is the problem!

1 Like