SubD Fill Command Inconsistency

subdringshanksize9.5.3dm (141.0 KB)
Hi. I attached a 3dm file as reference as well as these images. Does anyone know why when I execute the fill command on the left side, the faces behave differently than when i fill the right side. As far as I can tell the ring is symmetrical. It was made with SubDSweep1 and a cross section. Then I just selected all the faces of the top 2 sections and deleted. I want both sides to be filled like the left because when I bridge another object with the right side, it always causes a twist.

Moved to SubD category

why not reflect?


What is pointing @nickbranscum is correct.

I faced that behaviour during a live online course, few weeks ago .
After some experiments to try to understand, I was not able to bring a valid answer to those who asked me why this happen.

Reflect works but I consider this as a work around.
When the scenarios are 100% are identical (expect the location in space), I see no valid reason to get different results.

A clarification would help.

Rodolfo Santos

I’m not sure. I can’t reflect because the object I want to bridge to is different on both sides so I need to bridge each side independently. This happens every time; I sweep and then cut the top segments off. Then when I fill, the right side always does this.

Correct and not that logical.

It is always possible to re-reflect but as I said, that more like a work around that is painful to repeat.

Rodolfo Santos

Hello - I see that - my guess of the moment is that the difference may be due to the process traveling along the edges in opposite directions - but that is a wild guess, I will add this to the pile for the developer. Meantime, Cap does a good job here I think.

RH-64623 Fill: Inconsistent


What do you mean re-reflect exactly?

*edit: nevermind, I understand what you mean. Honestly not that time-consuming of an alternative and it worked perfectly. Thank you!

Is it possible to use cap to create 4 faces just like the fill command?

Hm - yeahh, does not look like it, I guess. Reflect is the way out, I would say, for now.


I see, the way I wrote may suggest that there is a Re-Reflect command existing in Rhino.

I was referring the action of simply repeating the process to work around this temporary limitation.

Fill the left empty region and run reflect again to get the same result on the right side
Not an elegant solution but till there will be a better one, we have to live with it.

Rodolfo Santos