Strange Gumball


#1

Is that normal:
Strange Gumball


#2

Hi,
I noticed also that if I create a simple plane surface, rotate it for example 45 °, then I choose Align to Cplane, is not working. But if I choose first Align to object then Align to CPlane then it works.


(Brian James) #3

Hi Dedo,

Yes, that’s normal (no pun intended). The reason that the GB aligns as it does the first time is because the box is an Extrusion Object ( http://docs.mcneel.com/rhino/5/help/en-us/information/lightweight_extrusion_objects.htm ). After you sub-object and move a face of the box it becomes a regular polysrf. At that point, there are six possible faces that align to object could reference so none are used and the GB stays where it is.

side note:
In the next service release of Rhino 5, the Gumball location is saved between sessions for single objects!


(Brian James) #4

This is probably because the GB setting was align to Cplane already and you rotated the plane using the GB which also rotated the GB. Clicking on Align to Cplane which is already selected isn’t seen as a Reset to that alignment. Use Reset Gumball in the GB settings instead and the alignment will reset to the current setting… in this case Align to Cplane.


#5

I understand, I guess it would be logical when you choose to Align to Cplane it checks the Cplane orientation first.
Thanks


#6

Thanks - got it! Waiting for the next SR6 :)))