Strange cropping in camera foreground

Hello all.
I use Rhino 6. For some reason, my camera is cropping my preview geometry in the foreground, and it appears cut oddly The display was working perfectly all week, but now suddenly it is not. I have modeled nothing in my foreground lately, changed the camera angle, or created clipping planes. The cropping changes if I zoom in or out, but still there is foreground cropping with a relative distance to the camera. Changing the display mode or cPlane also do not help. Restarting did not help.
Does someone have a solution?

I’m getting this same behavior in the latest service release version (updated today). When I zoom, geometry is clipping in the foreground, for both Rhino and Grasshopper objects. No clipping planes are enabled for the view.

Hello - is this behavior new with the update, or old behavior not fixed?


It just started happening today for me, in both the previous version, and the newest update (I updated earlier today).

Here’s my system info, if that’s helpful:

Rhino 7 SR6 2021-4-13 (Rhino 7, 7.6.21103.13001, Git hash:master @ 3d8b63e6571eb752e8348635aa75ec08cf87e183)
License type: Commercial, build 2021-04-13
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino
C:\Users\Owner\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.6.21103.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21103.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21103.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21103.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21103.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello- I am doubtful it matters, but just to eliminate the possibility, can you please disable the TwinMotion plug-in in Options > PLug-ins page then close and reopen Rhino?
Also, what happens when you toggle the ground plane on and off, anything?


Maybe this helps. One thing I did discover was that I had some stray pieces of geometry far from the project origin. The geometry was from an imported dwg file. I removed the geometry and restarted Rhino, and then the cropping was better. However, it still occasionally happens and at various degrees of cropping no matter how far geometry is from the origin. I wish I knew a quicker fix.

Pascal–Tried both of those, but neither seems to have helped. Thank you for your quick responses.

Megan–My geometry is also quite far from the origin (a few thousand feet, but nothing imported), but I’ve worked with many files like this before and haven’t run into this issue. It does seem to be specific to the file, as other similarly large files I’m currently working with aren’t showing this behavior.

Hello - can you send us the file? (, please include a link back to this topic in your comments) We’ve been seeing reports of this but have not been able to pin it down so far.


Just sent it to you–thanks!

Yep, thanks - but you need to give me access to the file on the Google drive. I poked the ‘request access’ button…