5A701 minor bug - STL mesh options window error

Using the latest version I selected and tried to export a polysurface as an STL, however I only got half of the STL options window as shown:

The export worked fine but I couldn’t see all the options to tweek! The exact same file worked and all options windows were displayed fine yesterday on the previous build.

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A701)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.2 (Build 14C109)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Third party kernel extensions
com.3dconnexion.driver (10.2.0)
com.avatron.AVExVideo (1.7)
com.avatron.AVExFramebuffer (1.7)
com.trusteer.driver.gakl_driver_2 (1)

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470S CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 660M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Western Digital: Elements 10A2
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Keyboard
3Dconnexion: SpaceNavigator
Iomega: USB to ATA/ATAPI bridge
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.2.1 310.41.15f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None

My bad - just noticed its a sizing issue as I can drag the corner of the window to see all the options. However, the window’s behaviour has definitely changed from the previous build.

No, my bad. I believe I broke this doing Autolayout work for translated strings. I’ll fix this ASAP. Thanks for reporting it.

Cheers Dan, it’s not exactly a major drama or high priority but thought it was worth flagging up!

I’m glad you said something! Thanks. It will be fixed in the next WIP.