Sticky setting for Split by Isocurve


#1

Selecting Shrink Surfaces=Yes when splitting surfaces by isoparms isn’t sticky. This is tedious when I’m doing repetitive splitting. Is it a bug, or is there a historical reason for not having it sticky?
Matt


#2

Hi Matt,

I think there was a bit of discussion about this some time ago and the consensus seemed to be that NOT shrinking should be the default. After all, it’s easy to shrink but not so easy (impossible) to “unshrink”

But you could put this on a button or alias: -split _isocurve shrink=yes

Steve


#3

Hmm, I didn’t know that it wasn’t sticky, but it’s not. There’s kind of a problem here where it’s an option in the Split command where a sticky shrink option in when splitting by curves or surfaces is really a bad idea, but by Isocurve it’s not. They should kinda be separate commands, as they were a long time ago.


#4

This behaviour, I think, changed in v5 – when the shrink behaviour became optional rather than the default result.

Surely one of the main reasons one would choose to use split at isocurve is to generate an untrimmed result. I don’t mind having the option to not shrink but it seems odd not to have the option defaulting to NO and then breaks the usual interface behaviour in this option not being sticky.

Can this be changed?

Phil - SimplyRhino UK


#5

I meant to say ‘to have the option defaulting to NO’


(Pascal Golay) #6

Hi Phil - I think this is unlikely to change - as Steve points out above, it became clear very quickly that you could make an irreversible mistake by having Shrink set to Yes, so you need to ask every time - a macro is the key, I think.

-Pascal


#7

I’d be happy if it was sticky, but upon first call of the command in each session it was ‘no’ by default. But if I’m splitting lots of surfaces by isocurve (as is often the case when, for example, breaking down helical staircase handrails to fit stock timber sizes) then having to repeatedly press t to toggle UV and also s for split does lose its novelty value after a while.

Though small things this, the change in nudge direction behaviour (Windows 10, compared to W7) when switching focus from one viewport to another and automatic deselection of points but not anything else when using Undo are my Rhino V5 pet hates!


(Pascal Golay) #10

Hi Matt - a macro like

! Split Pause Isocurve Shrink=Yes may help - it repeats on rmb click.

-Pascal