Step Export Missing?


#1

Hopefully I am overlooking something simple, but can’t seem to find the .step export format.

I am running the latest version, and looks like the step plugin is installed.

Version 5 SR9 64-bit
(5.9.40609.20145, 6/9/2014)
Commercial


#2

Updated. Looks like I have step import but no export. Any thoughts?


#3

Did you check the Tools --> Options --> Plug-ins to make sure that STEP was not turned off? Make sure they are checked ON. After you make the change, I would also re-start Rhino to make sure. See pic below.


#4

Yep they are both on, and I have restarted Rhino twice still no change.


#5

Although something does seem to be missing. I guess the next step is to try a Rhino re-install.


#6

Ok. Did a new install and nothing changed it was still missing. So re-installed the plug-in from C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins and it came back. I wonder if something isn’t right with latest installer???


(Pascal Golay) #7

Hi Dennis - this was with the SR 9 auto update, is that correct? There was a last minute bug fix in STEP export, I am pretty sure. @chuck, any idea is this is related, maybe? (STEP Export plug-in apparently not installed correctly in this case).

-Pascal


#8

Yes that is correct SR9 auto updated. Then I downloaded the rh50Release_x64_en-us_5.9.40609.20145 installer.


(Chuck Welsh) #9

I don’t think so. Tim fixed a problem in the way extrusions were handled in blocks with transformations not supported by STEP. I don’t see how this would affect the installer.


(Pascal Golay) #10

I was wondering if a version changed or something that was then not handled by the installer, not so much the fix itself.

-Pascal


#11

Same here (STEP is all on in Plugins), any idea how to solve this, need to export right now since a client is waiting for further model making… Thanks for your help


#12

I haven’t had the issue since, but the way I fixed it was installed the plug-in for C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins folder, but first I would check to make sure the plug-in is enabled from the options window.


#13

@djnelson75 thanks a lot man. yes will get into the folder and install it manually. it’s shown activated in the plugin menu…