STEP assembly import

I received a STEP assembly (top level and all its parts) from a client.
Rhino 6 couldn’t handle it.
Rhino 5 noted it was not standard and if I wanted to open it using “214” whatever that is.
This was successful in Rhino 5. And I saved it as the usual .3dm file (21mb)
Opening then in Rhino 6 and resaving, Rhino 6 saved the .3dm file now 36mb!
Not so much of an improvement in the new version if you ask me. My 2 cents.

Hello - if you can, please upload the (zipped) step file to to my (Pascal) attention.
When saving, try SaveSmall and see of that gets the file size more as you expect.


Sorry Pascal. Stuff is very proprietary, patent related.
That’s why I just related my experience having ver 5 attempt to work with it’s “214” try and ver 6 said “hell with you.”

I can’t guess how much time or interest you have in helping to get this fixed, but I suspect that since STEP is so important as a file transfer medium that the McNeel folks would like to get it figured out and fixed.

Is there any chance that either you or your client could prepare a STEP file that displays the same problem with no proprietary info?


It sounds like your file is written with a schema that is not directly supported by Rhino. If that’s the case, then Rhino attempts to read any part it can. I don’t know what would have changed between V5 and V6 to mess this up. Your description of what happens in V6 doesn’t tell me much.

Can you open your file in Notepad and just send me ( the first few lines?
They should look something like this, and won’t give away anything of the content of the file:


FILE_DESCRIPTION( (’’),‘2;1’);

FILE_NAME( ‘block’,‘2017-03-03T13:33:54-08:00’, (’’), (’’),‘ST-DEVELOPER v16.5’ ‘’);


I’m mainly interested in the FILE_SCHEMA line, but the rest helps. If you’re not willing to do that, maybe try changing your FILE_SCHEMA line to match the one above and see if you get better results.


Sorry for the delay in replying.
Importing (opening) a STEP assembly in Rhino6 does absolutely nothing. No warning no nothing. A blank canvas is then shown.
Importing (opening) a STEP assembly in Rhino5 results in a warning/info window showingrhino5%20warning%20214

When I select “yes” everything goes as I wanted with the import.
My question is why doesn’t Rhino6 accommodate me the same way.

I do see that V6 does not give the warning if I mess up the FILE_SCHEMA line in a file. But it should also just read what it can find and should be better than V5. Can you do what I suggested and send me the lines from the top of your file? Maybe there’s something odd about it that is different than I’m expecting.

Another thing to try is to take any STEP file that does read into Rhino V6 and change the top of that file to match the one that won’t read in. If that file will no longer read, then we have something to go on.

Also, which service release of V6 are you using? Help->About Rhinoceros.


Using the very latest service release 6R8 8-28-18.
I hope I’m not violating any NDA-- here is the first lines of the STEP:

FILE_DESCRIPTION((‘CATIA V5 STEP Exchange’,‘CAx-IF Rec.Pracs.— Model Styling and Organization—1.4— 2014-01-23’,‘CAx-IF Rec.Pracs.—3D Tessellated Data Validation Properties—0.5—2014-09-14’),‘2;1’);

FILE_NAME(’\\FILESRV\XXXXX\Current\4106 XXXXXX NMA Automated Clamp Up Swaging System\Communications\To XXXX\7.18.18 - Method B Collar Feed Models\Top Level.stp’,‘2018-07-18T15:57:24+00:00’,(‘none’),(‘none’),‘CATIA Version 5-6 Release 2016 SP5 HF3’,‘CATIA V5 STEP AP242’,‘none’);



I x’ed out revealing names
Thanks, Chuck.


I tried changing the header from a valid STEP to the assembly STEP and nothing worked. I even tried to change that 242 in the header to 214. Weird but you never know. Nothing in Rhino6.


" If you’re not willing to do that, maybe try changing your FILE_SCHEMA line to match the one above and see if you get better results."

Tried that too withthe same results, nothing, in Rhino6


AP214 Automotive Design has been supported for some time in R5 and I just took this screengrab from the export options window in R6 so I am curious as to this outcome.

Thanks for trying these. At least now we know it has nothing to do with the schema. Here’s another thought. Can you search the file for the word “document”. It may appear as part of a longer term, like applied_document_reference so don’t search for exact match. Case may be different, too. Probably all capitalized. I wonder if the file refers to other step files.

@Joseph_Culbert Are you asking about the option to export parameter space curves? Checking that box will cause Rhino to use a more complex entity to represent a trimming edge. Many applications, Rhino included, represent the trimming boundaries of surfaces by pairs of 3d and 2d curves. The 2d curves are in the surface’s parameter space and are called parameter space curves. Not many STEP exporters bother with them, forcing the importing program to create the 2d curves from the surfaces and the 3d curves. If you check that box, both the 3d and 2d curves will be put in the STEP file in an entity that says how they are related to the surface.

Thanks Chuck but your comments are over my paygrade. I have always had good results using the Rhino 214 export settings.

Hi Chuck,
This is the feature of an assembly STEP file. (Much like SolidWorks assemblies)
I have a folder with 130 of almost tiny STEPs and one file moderate in size 383kb named “top level.stp.”
If I open that top level file in Rhino5 it gives that warning I posted above. With success.
Rhino6 can’t handle and just gives me a blank stare. Not even an error warning.


Thanks for the information. We see very few files with external documents. Most applications, Solidworks included, put all the geometry and assembly information in the same STEP file. Catia uses separate files. I’ll see if I can find one and figure out what may have broken there. Most files that I get from customers are deleted once we fix the problem, unless they tell us we can keep them, and Catia users generally don’t want us to keep the files. Do you have other assembly files like this that do read into V6 correctly? Or do you have any that don’t which are not under NDA?

One requirement is that all of the tiny files have to be in the same directory as the top level file. I assume this is the case for you since you can read them into V5.

EDIT: I found one and it doesn’t work in V6. I’ll get right on it and should have it fixed for the next SR9 release candidate, probably on Tuesday. Thanks!

You all are the best. That’s why I bother to help out when something like this comes up.

A client is a major airline manufacturer so they have everything output in SolidWorks or Catia STEP files.

I’ve been using Rhino since I think about version 1.5 to process these major CAD files to Illustrator output for patents, not real engineering. Lately with the advent of Astute Graphics add ons, Rhino 2D output is tremendously easier to process. (great for my creeping old age)

Thank you for your efforts.


Thank you very much for pointing out the problem! I just put in a fix. It will be in the next SR9 release candidate. If you go to Help->Check for updates and set the frequency to Service release candidate, you’ll get it automatically, probably late Tuesday. Please let me know whether or not it works as expected.

1 Like