STEP file won't load

I received a mechanical model in STEP file format that Rhino 6 couldn’t handle.
It just sat there doing nothing. (I let it sit for 30 minutes)
I tried Rhino 5 and it loaded (after 15 minutes of creating 6334 polysurfaces) no problem.
Someone suggested a while back keeping Rhino5 for just this very reason.

Hello - please zip and send us the Step file at, to my attention.

Please add a link to this conversation in your comments.



Sorry. Too proprietary to share.
That’s why I thought I’d mention the issue without specifics.
Make 2D after cleaning up the file by 60% still is very rough also. Arbitrary lines all over.
I don’t fault Rhino. It’s excellent software.
It’s just hard to play with the big boys. The really big boys.

Well, since there’s zero hope of doing better without an example file…


since it could be a problem with the surfaces due to the translate to step forrmat, you should try with other packages to open it and re export it. there are few of them free on the web which can handle step files.

I’ve had these issues too, in the earlier releases of Rhino 6. I’ve shared confidential files with Pascal and Chuck with the stipulation that they must remain private and be destroyed after the issues are solved. I’ve never had reason to believe this didn’t happen.

It’s up to you, but like Pascal says, without an example, you’re not going to get a solution.


I’ve been sharing with McNeel problem files that are extremely proprietary, some in new-to-the-world industries, way before we applied for patents. I’ve been doing this for over 15 years now. I’ve always tell employers and clients that McNeel is a strategic partner of our work and our process. If you can’t trust them or let them help you solve your technical problems you have much much bigger problems.

Stop talking like a 12yo. Most of the work in many industries is built with or touched by McNeel tools. Leading players in architecture, construction, heavy equipment, automotive, aerospace, medical products, housewares, consumer electronics, apparel, footwear, outdoor equipment, performance sports, racing… All work done by big, medium and small men, and women. Chill.

I’ve also run into this problem recently. I sent a step file to the support upload link. It is actually a file that I exported from Rhino 6 that now I can’t load back in.

I’m sympathetic to not being able to share certain models though. Some NDAs with clients depending on the nature of the project are just that strict.

Thanks, we’re taking a look at it.
@sc_o - this file reads in here in the latest - now, there have been some fixes, so it could just be that I’m enough ahead of the build that you have that it is fixed… can you please run
SystemInfo in Rhino and paste the results here?
Also, what happens when you try - error message, crash, empty file, or?



I’ve been doing this work for 33 years.
I’m talking about myself, dealing with clients with unlimited funds sending me files that are more detailed than they need to be cuz they’re lazy and well, just don’t have to.
Please remove your MAGA hat before entering the forum.