Stay in Fullscreen

Is there any way to go to Fullscreen mode and make it so that ESC doesn’t revert? Some tasks I like to have fullscreen enabled, but I occasionaly hit ESC a few extra times and it reverts to my normal layout.

You could use a NewFloatingViewport and then maximize that to fullscreen? Does that help?

You can use the dashed version of the command and disable escape:
Command: -Fullscreen
Set fullscreen options ( ShowLayer=No ShowCommand=No ShowStatus=No ShowProperties=No ShowMenu=No ShowTitle=No ShowFloating=No DisableEscape=Yes ):


cool… I learned something new today! Thanks Jess.

So if you disable ESC how do you exit fullscreen?

Hey Dan,

By typing Fullscreen again… It’s a toggle. Even if the command line isn’t shown in fullscreen mode, typing still works.


Good to know.



Thank you Jess and Helvetosaur! Super useful.
I just set up an alias:

-Fullscreen DisableEscape=Yes _Enter

Now I have a great, quick way to work in full screen.