Status bar


#1

Hi!
Very concerned about this issue…
Sometimes I work in Matrix3d. Matrix has its own toolbar with snap and layers. I used to the interface of Rhino. and for me not comfortable to use Matrix tools. At the starting the Matrix, “Status bar” never opens by default. Every time then I run Matrix3d, I have to go to Option> Appearance> Show the fllowing items> Status bar. How to make so that the “Status bar” in Matrix3d ​​always will open?

Thanks
-Leex


How to autorun the rhino script after 5 seconds after the start of the Rhinoceros?
(Brian James) #2

Hi Leex,

This sounds like a user rights issue where the toolbar file for Matrix is stored. If they use the Rhino preferences for the user then this might also be due to running Rhino as non admin. I’d first try right clicking the Rhino program shortcut and choosing run as admin. If the Matrix status bar setting doesn’t stick after that, I’d look into where that preference or toolbar file is stored for the plugin and check that you have write access for that folder.

Have you tried to contact the Matrix support people as well? They may know more… I don’t have Matrix here to test this unfortunately.


#3

Hi Brian!

Run as administrator does not solve the problem.
A year ago I contacted the developers of the plugin. They said that this was done for convenience in the matrix. The status bar does not open by default to save screen space.

Is it possible to force run a status bar with scripts or macros?
like that
Rhino options > General > Run these commands every time Rhino starts: (macro to run the status bar)


#4

Yes. Just put _StatusBar in that box… (hope it works with Matrix)
:smile:

–Mitch


#5

If that doesn’t work, you can also try putting the following in there…

! _NoEcho _-Runscript (Rhino.AppearanceDisplay 2, True)

#6

Hi Mitch!

! _NoEcho _-Runscript (Rhino.AppearanceDisplay 2, True) 

Statusbar appears for a split second, then disappears

-Leex


#7

Wow, Matrix must be watching this and automatically reacting… Very bizarre… :scream: