Sr9 Screen redraw problem not drawing closed curves as closed

In the lastest sr Version 7 SR9 (7.9.21222.15001, 2021-08-10)
I am now getting incomplete drawing of closed curve linework in the viewport. Doesn’t matter if I’m in wireframe or shaded or a custom view mode. Closed curves are not completely drawn until I zoom in and some are drawn closed while others are not. This can play havoc when you need closed curves and zoom out and you see random ones are not closed. I know these are all closed curves as I ran the selclosed curves command on them and when I zoom in they close up and redraw properly. This wasn’t happening in the last sr.

Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15001,
License type: Commercial, build 2021-08-10

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [95% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 530 (Intel) Memory: 1GB, Driver date: 11-18-2018 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 4GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
E:\rhino3d\BoltGen\BoltGen1_62.rhp “BoltGen”
E:\Downloads\elefront411\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\WebCam (b03d9978-150a-4297-95e0-d8a50df7c0b0)\\WebCam.rhp “WebCam”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.9.1.565\PanelingTools.rhp “PanelingTools”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2020.12.7.446\SectionTools.rhp “SectionTools”


Hi @3dsynergy
Start by updating your graphics cards drivers - 3 and 1 year old. If problem persists, try disabling the non-native plugins like twinmotion. But the drivers are a good place to start, I think.
HTH, Jakob

Hi @Normand,
Sorry I didn’t get back to you. You’re right, I just have been so busy and I can’t break anything until I get most of these jobs underway then I’ll update my drivers. I don’t think this is a plugin problem it looks like open GL is not sampling fine enough when the user zooms out or perhaps my monitor is not fine enough to catch those pixels.

Hello - the first thing to try is to disable these plug-ins in Options > Plug-ins page, and the close and restart Rhino and see if there is any change. Your Nvidia driver could use an update as well.


Do you know that this is new to SR9? I can’t recall any code changes to curve draw ing in recent service releases.

Hi @stevebaer,
I didn’t notice it before. The reason I saw it was because someone sent me a revised file that they reworked in ai and dwg format. I imported the dwg to find many flaws and closed those crvs/flaws. Then used selclosed crvs. Only to notice that in the viewport the curves looked open as you can see in the screen shot. It’s kind of disconcerting because we rely on our eyes/visual clues to model and when I see an open curve when it should be closed is a bit of work flow problem.
If you want I can send you this dwg file. I’m still seeing it in sr10.

Thanks Pascal,
I try that when I get a bit of time.