Splash screen

I have mentioned this before, but the situation persists, so I thought I would relaunch the issue…

I don’t think it’s very user-friendly that Rhino for Mac just “hangs” there waiting for you to choose a new template or a file… There really needs to be a timeout like on Windows and then it should just open a new blank file with the user’s default template.


1 Like

I agree, this is weird. I thought maybe it is an acceptable thing in mac land and I was just a macnewbie, , but I always find it slightly odd.


There are also a few in Windows land, like Word 2013 - it won’t open a blank document by default, you have to choose form a sort of splash screen - and there are a few others as well (Illustrator?)… This behavior always exasperates me…


I can understand this. At the same time, I’m on-the-fence…

In Rhino 5 for Windows, the Splash Screen RSS feed sometimes shows me stuff I might want to read and I can recall many a time that I’ve had just enough time to scan the list but as I’m moving my mouse over to click something, it starts to fade away. Many Windows splash screens that disappear after a load-time don’t really display anything that I might want to interact with. To be totally honest, having windows (that you can interact) with that disappear is kinda weird…but justifiable in some circumstances, I understand.

@pascal, Many Apple-developed OS X applications exhibit the behavior that Rhino for Mac’s Splash Screen/“Chooser” does: Xcode, Pages, Numbers, Keynote. Many non-Apple-developed OS X applications do something similar. Actually, lately, it seems that template-based applications like Keynote and Numbers are doing this thing where they present a finder window to create a file and then present a template chooser. I understand why Apple is doing this, but I’m not sure it’s an improvement on the Chooser paradigm (it really reminds my of Microstation, actually).

Minor points:

  • Until recently, reminding users that this is a WIP that expires has been useful. Hopefully, this will be a moot point soon.
  • Hitting Command+N works swimmingly :wink: from the Splash Screen/“Chooser.”

it wasn’t always that way but more&more, especially with apple applications, you always have to do something upon launch before a document comes up.
(unless you launch an app by double-clicking a file type which is associated with the program… then the splash will bypass)

it may or may not be because osx handles autosaving instead of individual applications and they think it’s best for the autosaving/versioning to happen in the file itself as opposed to a separate autosave file or location… so generally, you create/save a file first then work on it instead of the past where you’d work on an unsaved blank doc then save it at the end.

or maybe a ‘show this at start up’ check box / preference ?
personally, i’d turn it off so rhino launches straight into a new document every time and use the dock’s recent files feature or ‘new using template’ within rhino if i want to open something previously worked on…

that said, it’s probably pretty helpful at times for people newer to rhino and it might not be such a good idea to allow them to turn the splash screen off so readily (because they might not realize they’re turning off something they may need or not know how to get it back etc).

maybe a preference tucked away in Rhinoceros-> Preferences instead of a checkbox on the splash screen?

1 Like

I’d favor this option. Added to the pile (MR-1432)

This is a different issue, but I’ve noticed the last couple of builds that after installing a new WIP, when I launch Rhino for the first time, the splash screen doesn’t come up on-screen. The little Rhino in the dock does its dance and then just sits there, with a black dot to show it’s running. Looks like nothing’s happening, that the install wasn’t successful or something, but that’s not actually the case…

If I click on the Rhino in the dock again, then the splash shows up, I can choose a document/template and Rhino opens like it should. Thereafter, Rhino behaves normally, this scenario only happens the first time I run Rhino after a WIP install.


ditto for me :point_up:

I get the same thing. I never noticed this before…weird. Logged in MR-1468.