Splash Screen Disappears Too Quickly

Hello,

When launching Rhino, the splash screen appears for a second or two then disappears before I have time to interact with it.

Any way to make the splash screen stay longer?

Rhino 8.3, Windows 11.

Thanks!

I found the splash screen disappearing is happening when a custom template is loaded as default.

If I reset the default template to one that comes with Rhino such as Small Objects - Millimeters, then the splash screen will stay as long as the mouse hovers over it.

Even when it is working as intended, I’m not a fan of it disappearing as soon as the mouse moves off it(or never goes over it) as I may be clicking on other monitors as Rhino loads and then I miss the splash screen.

  1. Can we get the splash to stay when loading custom templates as default?

  2. Can we get an option to make the splash screen stay visible until it is actually closed by clicking the X or once an existing file or new file from template has been clicked?

Thanks

This makes me chuckle a little. We added all the bells and whistles to the splash screen back in Rhino 5 to hide the fact that it took forever to start. What is it that you are trying to get to from the splash screen when it closes too quickly?

1 Like

Hi Brian.

Glad I wasn’t around for the really slow days of Rhino 5. haha I like the splash primarily for the quick 1-click visual access to recently edited designs. Seeing an image makes it easier to identify and faster to jump back into various projects.

Could I live without it, I suppose. But then why have it there at all? I mean if it’s going to exist and pop up, it might as well stay long enough to be useful. Otherwise just get rid of it. I’d prefer to keep it and have it stay until I’ve chosen an action(without having to hover over it either). Most drawing programs I’ve used such as CorelDraw, Photo-Paint, Photoshop, Illustrator etc have similar start screens, usually with a check box or preference to disable the start screen on program start-up for those who don’t want it. Seems like the logical behavior that Rhino should follow.

Thanks

Thanks, I logged this as
RH-79254 Add option to keep splash open

Thank you kindly!